Tree Style Tab causes unresponsive bookmark toolbar

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: mjf, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
When running an up-to-date Nightly on OSX with the Tree Style Tab toolbar enabled, the bookmark toolbar doesn't respond to clicks.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:56.0) Gecko/20100101 Firefox/56.0
Version: 56.0a1
Build ID: 20170725144001

Disabling multi-process doesn't change anything.  Disabling Tree Style Tab does fix the issue. I've seen this happen on both OSX 10.11 and 10.12.
I can confirm the bug, with this error in the console:

> TypeError: aView is undefined 1 bookmark.js:501:6
> PlacesUIUtils.openNodeWithEvent resource://treestyletab-modules/bookmark.js:501:6
> BEH_onCommand chrome://browser/content/browser-places.js:952:7
> oncommand chrome://browser/content/browser.xul:1:1
Flags: needinfo?(yuki)

Comment 2

10 months ago
It seems to be tracked at:
[Nighlty] Unable to open bookmark entries by mouse clicks due to Bug 1354159 · Issue #1298 · piroor/treestyletab
https://github.com/piroor/treestyletab/issues/1298

And already fixed by this PR:
Fix #1298 by mjsn · Pull Request #1300 · piroor/treestyletab
https://github.com/piroor/treestyletab/pull/1300

Until I release a new version, you'll use the development build:
http://piro.sakura.ne.jp/xul/xpi/nightly/
Flags: needinfo?(yuki)
Great, thanks.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.