bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"origin" header should be "Origin" (title-case)

RESOLVED DUPLICATE of bug 1277496

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1277496
a year ago
a year ago

People

(Reporter: josh, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8890017 [details]
headers.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

make a CORS request (GET).  Assuming page is at http://localhost

Windows 10 54.0.1 (64-bit)


Actual results:

The Origin header is being submitted in all lower case "origin" - this isn't correct, and it is breaking filters. 

origin: http://localhost


Expected results:

The Origin header should be submitted in Title Case just like all of the other headers (and HTTP spec). 

Origin: http://localhost
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277496
You need to log in before you can comment on or make changes to this bug.