Add support for English India (en-IN) in firefox

RESOLVED WONTFIX

Status

Mozilla Localizations
Other
--
enhancement
RESOLVED WONTFIX
a year ago
9 months ago

People

(Reporter: Leo_sk, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170725030209

Steps to reproduce:

no option or language pack for english India. It has considerable userbase but still no pack availaible till now. Existing options en-US, en-GB, en-ZA, differ from the default date and time format used in India. Should be added as input datetime is soon to be added to stable branch
Severity: normal → enhancement
Component: Untriaged → Other
Product: Firefox → Mozilla Localizations
Version: 56 Branch → unspecified
en-GB and en-ZA are full localizations, maintained by volunteers.

Not sure which differences there are between en-IN and en-GB, but you should be able to rely on your regional settings without an en-IN language pack.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 months ago
As far as vocabulary and spellings go, en-GB is suffecient. Problem is with date, week or time format. Though each en-US, en-GB and en-ZA have some components that would match en-IN, none of them satisfies it completely. Full localization may be very resource intensive, a way to selectively enable indivudual components from different localizations can suffice
(Reporter)

Comment 3

9 months ago
Or if firefox can borrow them from os settings. At this time, i can confirm it doesnt take them from windows or linux.
Try setting intl.locale.matchOS to true in about:config
http://kb.mozillazine.org/Intl.locale.matchOS

I don't think the support is fully there for 56, but 57 should be in better shape on that front.
(Reporter)

Comment 5

9 months ago
Tried in firefox 58 on windows 10. Format is not system format but en-US
Hi Leo_sk! Actually, you shouldn't need to set `intl.locale.matchOS` for it to work in Nightly.

Basically, in Firefox 58 you should be able to use Firefox in en-GB or en-US and if your regional preferences in Windows are set to en-IN, we should pick your date/time and number formatting.

(because it uses the same language, `en`).

Can you please provide me more information and I'll try to reproduce:

1) Open your developer console and in Settings>Advanced check a box by "Enable browser chrome and add-on debugging toolboxes"
2) Open browser console (different from dev console but also in developer tools)
3) Paste here the results of:
4) Service.locale.getRequestedLocales();
5) Service.locale.getAvailableLocales();
6) Service.locale.getAppLocalesAsLangTags();

And can you confirm that in Windows you have your regional preferences set to English (India)?

Lastly, can you point out to the place in Firefox UI where you're verifying that the number/date formatting doesn't follow what you'd expect?
Flags: needinfo?(sk.griffinix)
(Reporter)

Comment 7

9 months ago
i am unable to find service.locale in browser console. I have everything ticked. also i followed step 1. i will attach screenshot of the browser console if anything wrong has been done.
(Reporter)

Comment 8

9 months ago
Created attachment 8923503 [details]
Browser console
Flags: needinfo?(sk.griffinix)
You need to type those commands at the bottom of the window, and press enter (the input field starting with >>)
(Reporter)

Comment 10

9 months ago
Services.locale.getRequestedLocales    array ["en-Gb,"en-US]
GetAvailableLocales "en-GB"
getAppLocalesAsLangtags  "en-GB"
(Reporter)

Comment 11

9 months ago
Also in windows, language is english india, and all date, time, settings are correct
Thank you! I'll investigate and try to reproduce now.
Flags: needinfo?(gandalf)
You need to log in before you can comment on or make changes to this bug.