Closed Bug 1384354 Opened 3 years ago Closed 2 years ago

Intermittent /css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html | Testing mix-blend-mode/mix-blend-mode-transition.html == mix-blend-mode/reference/mix-blend-mode-transition-ref.html

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jmaher)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 file, 1 obsolete file)

Duplicate of this bug: 1384374
There have been 31 failures in the last week.
The failures occur on linux64-stylo-disabled and Linux x64 platforms.
The only affected build type is the debug one.

Here is a recent log file: https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=145300015&lineNumber=4755
And a snippet with the failure:

[task 2017-11-16T13:08:50.620Z] 13:08:50     INFO - PID 2531 | 1510837730608	Marionette	INFO	Testing http://web-platform.test:8000/css/compositing-1/mix-blend-mode/mix-blend-mode-svg.html == http://web-platform.test:8000/css/compositing-1/mix-blend-mode/reference/mix-blend-mode-svg-ref.html
4747
[task 2017-11-16T13:08:50.628Z] 13:08:50     INFO - PID 2531 | ++DOMWINDOW == 69 (0x7feae0009800) [pid = 2620] [serial = 69] [outer = 0x7feaee7dd800]
4748
[task 2017-11-16T13:08:50.685Z] 13:08:50     INFO - PID 2531 | ++DOMWINDOW == 70 (0x7feae000c800) [pid = 2620] [serial = 70] [outer = 0x7feaee7dd800]
4749
[task 2017-11-16T13:08:50.725Z] 13:08:50     INFO - TEST-PASS | /css/compositing-1/mix-blend-mode/mix-blend-mode-svg.html | took 121ms
4750
[task 2017-11-16T13:08:50.726Z] 13:08:50     INFO - TEST-START | /css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html
4751
[task 2017-11-16T13:08:50.743Z] 13:08:50     INFO - PID 2531 | 1510837730730	Marionette	INFO	Testing http://web-platform.test:8000/css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html == http://web-platform.test:8000/css/compositing-1/mix-blend-mode/reference/mix-blend-mode-transition-ref.html
4752
[task 2017-11-16T13:08:50.758Z] 13:08:50     INFO - PID 2531 | ++DOMWINDOW == 71 (0x7feae000f800) [pid = 2620] [serial = 71] [outer = 0x7feaee7dd800]
4753
[task 2017-11-16T13:08:50.815Z] 13:08:50     INFO - PID 2531 | ++DOMWINDOW == 72 (0x7feae0013800) [pid = 2620] [serial = 72] [outer = 0x7feaee7dd800]
4754
[task 2017-11-16T13:08:51.040Z] 13:08:51     INFO - PID 2531 | 1510837731037	Marionette	INFO	Found 10000 pixels different, maximum difference per channel 14
4755
[task 2017-11-16T13:08:51.077Z] 13:08:51     INFO - TEST-UNEXPECTED-FAIL | /css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html | Testing http://web-platform.test:8000/css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html == http://web-platform.test:8000/css/compositing-1/mix-blend-mode/reference/mix-blend-mode-transition-ref.html

:jgraham, could you please take a look at this? Thank you.
Flags: needinfo?(james)
Whiteboard: [stockwell needswork]
I'm pretty sure this test is broken and probbaly takes the screenshots too early, but it would be good for someone in Layout to take a look. It seems like it should have reftestWait to allow the transition to run before taking the screenshot.
Component: web-platform-tests → Layout
Flags: needinfo?(james)
Product: Testing → Core
Version: Version 3 → unspecified
The failure pattern is the same as in Comment 18.
There are  32 failures in the last 7 days.
Flags: needinfo?(bugs)
Yeah, that test is totally bogus and should be disabled.

(It's using setInterval -- who knows why, it should just flush styles and then trigger the transition, or at very least use requestAnimationFrame. Even setTimeout would be better. Then the reference is testing that the transition has finished without actually waiting for it -- as James points out it should use reftestWait to time the snapshot. And furthermore, because it's expecting the transition to have finished, it's not actually testing transitions at all -- you'd get the same result if no transition ran.

I suspect the test worked originally as a manual test and then someone tried to shoehorn it into being a reftest without actually checking if it made sense.)
Flags: needinfo?(bugs)
Attached patch remove test case (obsolete) — Splinter Review
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8933297 - Flags: review?(bbirtles)
Don't we need to run ./mach wpt-manifest-update too to update MANIFEST.json?
Flags: needinfo?(jmaher)
Attached patch remove test caseSplinter Review
thanks for the reminder there- I do this infrequently enough that I forget all the steps.
Attachment #8933297 - Attachment is obsolete: true
Attachment #8933297 - Flags: review?(bbirtles)
Flags: needinfo?(jmaher)
Attachment #8933687 - Flags: review?(bbirtles)
Attachment #8933687 - Flags: review?(bbirtles) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/032b89b764b9
Remove bogus test /css/compositing-1/mix-blend-mode/mix-blend-mode-transition.html. r=birtles
https://hg.mozilla.org/mozilla-central/rev/032b89b764b9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.