New update of Lightning 5.4 disabled DUO / Google Calendar access

UNCONFIRMED
Unassigned

Status

Calendar
Provider: GData
UNCONFIRMED
3 months ago
2 months ago

People

(Reporter: Mel RLL, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8890155 [details]
lightening error.pdf

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122310

Steps to reproduce:

A continuous problem for the environment I have, Google calendar behind DUO login requirement for 2 part authentication.


Actual results:

After the upgrade to Lightning 5.4, my calender access to google failed and I am no longer able to access or update certain aspects of my calendar.  Some that do not require the DUO access (which cannot be turned off) still display, but all are locked.  I have this problem on all versions of Thunderbird I am running on 5 different machinces I am running.  3 are running Windows 10, 2 are running Linux, one, 16.04 and other 14.04.  Some are virtual environments under Oracles Virtual box.  All have the same problem.

The file below PDF is a set of screen I captured along the way include the log file from Thunderbird.


Expected results:

Before the update from 4.7 to 5.4 Lightning, there were no problems.  No I have no access. Not sure what else I can do as the Log file indicates a number of "unexpected errors".

Comment 1

3 months ago
Which duo product are you using?
Flags: needinfo?(rossollo)
Hey Mel, can you send me the email you are using to log in? I tried the email you used when sending me private email me but that said it found no Google Account. I will not be trying to log in as you, but need something to trigger your DUO page. I've tested this with Mozilla's DUO auth and it works fine there.
Component: Untriaged → Provider: GData
Product: Thunderbird → Calendar
Version: 5.0 → unspecified
(Reporter)

Comment 3

3 months ago
Sure, the google account is "rosso@andrew.cmu.edu" sorry about that.

Is there anything else I can send you?  I really appreciate your looking into this.

It is consistent with every version I run.  I was waiting to test my Virtual Linux last night and my two windows systems.  The both upgraded and then gave the error.

I even completely wiped out my Thunderbird and started again from a complete reinstalled on one computer to no avail.

The DUO on my phone is: 3.16.4 Build 316403

No version number is listed on the DUO screen asking for authentication, but when I click on 'what is this' it goes here:
https://guide.duo.com/prompt

The other button just give the CMU help center.
Flags: needinfo?(rossollo)
(Reporter)

Comment 4

2 months ago
I tried it this morning and the DUO appeared to work.  I had to recreate the calendar, but everything loaded correctly and now I am able to enter into the calendar on Thunderbird and have the entries reflected on my calendar on Google.  All appears to work.
You need to log in before you can comment on or make changes to this bug.