Update Debugger frontend (7/25/2017).

RESOLVED FIXED in Firefox 56

Status

defect
P3
normal
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

unspecified
Firefox 56
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

2 years ago
No description provided.
Assignee

Updated

2 years ago
Assignee: nobody → jlaster
Priority: -- → P3
Assignee

Comment 1

2 years ago
Posted patch 7-25-1.patch (obsolete) — Splinter Review
Attachment #8890165 - Flags: review?(jdescottes)
Comment on attachment 8890165 [details] [diff] [review]
7-25-1.patch

Review of attachment 8890165 [details] [diff] [review]:
-----------------------------------------------------------------

I seem to have spotted a regression worth investigating.

STRs:
- add a breakpoint
- hit the breakpoint
- resize firefox to switch back and forth between horz/vert layouts
- try to step over / continue -> buttons no longer work

In the browser console I get "TypeError: selectedSource.get is not a function[Learn More]"

Sidenote: tag is missing for v0.9.0 on GitHub. Also package.json still contains 0.6.0 :D
The reason I'm bugging you about this is that, as a reviewer, I like to have an idea of what I am testing in a bundle. 
What are the new features, what are the bug fixes etc... Not that I want to validate everything, but if I see anything that might behave differently in the toolbox vs in launchpad, I'll do some extra testing there.
Attachment #8890165 - Flags: review?(jdescottes)
(Probably better to fwd the r? to someone else by the way, won't really have time this week)
Assignee

Comment 5

2 years ago
Nice find with the regression. 

Oh shit, i've forgotten about doing package.json because it's not an NPM publish. I'll update the release.
Assignee

Comment 6

2 years ago
Posted patch 7-25-2.patchSplinter Review
Attachment #8890165 - Attachment is obsolete: true
Attachment #8890359 - Flags: review?(jdescottes)
Comment on attachment 8890359 [details] [diff] [review]
7-25-2.patch

Review of attachment 8890359 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! reported regression has been fixed.
Attachment #8890359 - Flags: review?(jdescottes) → review+
Assignee

Updated

2 years ago
Keywords: checkin-needed

Comment 8

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/27e0a6f71b64
Upgrade Debugger Frontend v0.10 (7/25). r=jdescottes
Keywords: checkin-needed

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/27e0a6f71b64
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Depends on: 1388128

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.