Mozilla crashes under Korean UTF-8 locale if I try to enter Korean chars.

VERIFIED DUPLICATE of bug 128875

Status

()

Core
Internationalization
--
critical
VERIFIED DUPLICATE of bug 128875
16 years ago
16 years ago

People

(Reporter: Jungshik Shin, Assigned: Roy Yokoyama)

Tracking

({crash, intl})

Trunk
x86
Linux
crash, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When I launch Mozilla under ko_KR.UTF-8 locale and
try to enter some Korean characters in a composer
(or anywhere in Mozilla), Mozilla dies immediately
after I press the key combination to switch to Korean
input mode from English input mode. That is, I cannot
enter a single Korean character in Mozilla under
ko_KR.UTF-8 locale. 

Steps to reproduce:

1. XLC_LOCALE file for ko_KR.UTF-8 or en_US.UTF-8 locale file
  in XFree86 4.x is sort of broken so that it has to be
  replaced with what I'm gonna attach.

2. In /usr/X11R6/lib/X11/locale, make a new directory
    'ko_KR.UTF-8'
3. In the same directory, replace the following two lines
   
  ko_KR.UTF-8      en_US.UTF-8/XLC_LOCALE
  ko_KR.UTF-8  :   en_US.UTF-8/XLC_LOCALE

with 

  ko_KR.UTF-8      ko_KR.UTF-8/XLC_LOCALE
  ko_KR.UTF-8   :  ko_KR.UTF-8/XLC_LOCALE

4. Copy XLC_LOCALE (I'm going to attach) to 
   ko_KR.UTF-8 directory and make it world-readable
    (also make sure that the directory ko_KR.UTF-8
   is accessible by everyone)

5. Launch Korean XIM server ami
   $ LC_ALL=ko_KR.eucKR  ami
    or
   $ LC_ALL=ko_KR.eucKR  ami_applet

6. set the XMODIFIERS env. variable 
 
   $ export XMODIFIERS=@im=Ami
7. Launch mozilla under ko_KR.UTF-8 locale

    $ LC_ALL=ko_KR.UTF-8 mozilla 
8. Go to Windows|Compose

9. Try to enter some Korean characters
   You can switch to Korean mode
    by pressing left-shift key and space
     simultaneously. 
10. Mozilla crashes right away.
(Reporter)

Comment 1

16 years ago
Created attachment 79963 [details]
XLC_LOCALE file for ko_KR.UTF-8 

This file has to be put as XLC_LOCALE
in /usr/X11R6/lib/X11/locale/ko_KR.UTF-8

Comment 2

16 years ago
Jungshik: Could you provide your build id and Talkback incident ID? If not,
could you install the latest nightly build and try it again?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Severity: major → critical
Keywords: crash
(Reporter)

Comment 3

16 years ago
Adam:

Sorry I forgot to specify the build ID. It's 1.0RC1 (2002041711).
As for the talkback ID, how can I get one? I've filed a number
of talkbacks vis talkbak agent, but I've never received any 
talkback ID.
I'm running Redhat 7.1 (with XFree86 4.1.0). 
If necessary, I'll try the latest nightly from the trunk (or
should I try 1.0-branch nightly build?).
(Reporter)

Comment 4

16 years ago
Katakai-san,
Could you try Mozilla 1.0RC1 under ja_JP.UTF-8 locale on both
RedHat Linux (if you have one handy) and Solaris? 
For RedHat 7.x, you may(or may not) have to do for ja_JP.UTF-8 
XLC_LOCALE file something similar to what I did for
ko_KR.UTF-8. 
Keywords: intl

Comment 5

16 years ago
To get the Talkback ID's go to your mozilla directory and go to
mozilla/components/talkback/, there start talkback, it'll give you a list with
the IDs. Thank's a lot.
(Reporter)

Comment 6

16 years ago
Thank you for your info. about getting talkback ID. 
The ID for my crash report is TB5373173K. Can I access my
report from outside netscape? Or is it restricted? 

Comment 7

16 years ago
You cannot access it outside Netscape. =(

Comment 8

16 years ago
Jungshik, can you check bug 128875 ? Is this same problem?

How about when you set 

user_pref("xim.input_style","over-the-spot");

?

I believe this is a bug of Xlib on on-the-spot mode.
(Reporter)

Comment 9

16 years ago
Katakai-san,

Thank you for your prompt response. Yes, I think this one
is a duplicate of 128875 except that setting
xim_input.style to 'over-the-spot' doesn't help.
I'll add more details there.
(Reporter)

Comment 10

16 years ago
> user_pref("xim.input_style","over-the-spot");

Sorry I was wrong. I made a mistake when putting the line above.
Anyway, with the above setting, Mozilla doesn't crash. 
I think this bug is certainly a duplicate of bug 128875 in
all aspects. I'm gonna mark it as such if I'm allowed to
by bugzilla :-)


*** This bug has been marked as a duplicate of 128875 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.