Generate Marionette server API documentation

RESOLVED FIXED in Firefox 56

Status

enhancement
P4
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ato, Assigned: ato)

Tracking

Version 3
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(6 attachments)

Much of the Marionette server code in testing/marionette/*.js is
documented with useful type information.  It would be useful to
generate these docs using jsdoc (or equivalent).

When https://bugzilla.mozilla.org/show_bug.cgi?id=1381920 is fixed,
it will be possible to browse HTML documents on searchfox.org.  This
would make the generated API documentation self-hosting.
Assignee: nobody → ato
Status: NEW → ASSIGNED
Priority: -- → P4
Comment on attachment 8890382 [details]
Bug 1384517 - Render Marionette README as HTML;

https://reviewboard.mozilla.org/r/161500/#review166984
Attachment #8890382 - Flags: review?(dburns) → review+
Comment on attachment 8890383 [details]
Bug 1384517 - Provide jsdoc rules for testing/marionette;

https://reviewboard.mozilla.org/r/161502/#review166988
Attachment #8890383 - Flags: review?(dburns) → review+
Comment on attachment 8890384 [details]
Bug 1384517 - Fix testing/marionette API docs;

https://reviewboard.mozilla.org/r/161504/#review167000
Attachment #8890384 - Flags: review?(dburns) → review+
Comment on attachment 8890385 [details]
Bug 1384517 - Add "marionette doc" subcommand to generate docs;

https://reviewboard.mozilla.org/r/161506/#review167016
Attachment #8890385 - Flags: review?(dburns) → review+
Comment on attachment 8890386 [details]
Bug 1384517 - Exclude testing/marionette/doc from linting;

https://reviewboard.mozilla.org/r/161508/#review167018
Attachment #8890386 - Flags: review?(dburns) → review+
Comment on attachment 8890386 [details]
Bug 1384517 - Exclude testing/marionette/doc from linting;

https://reviewboard.mozilla.org/r/161508/#review167028

r+ but this is more of I assume this is correct since its autogenerated.
Comment on attachment 8890387 [details]
Bug 1384517 - Generate Marionette server API docs;

https://reviewboard.mozilla.org/r/161510/#review167030
Attachment #8890387 - Flags: review?(dburns) → review+
Comment on attachment 8890386 [details]
Bug 1384517 - Exclude testing/marionette/doc from linting;

https://reviewboard.mozilla.org/r/161508/#review167034
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a61f3b97e51
Render Marionette README as HTML; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/9c46b91899fa
Provide jsdoc rules for testing/marionette; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/c530d257c6d2
Fix testing/marionette API docs; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/31dcb89c3c4b
Add "marionette doc" subcommand to generate docs; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/cba13cf446d5
Exclude testing/marionette/doc from linting; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/9092331c31e4
Generate Marionette server API docs; r=automatedtester
Duplicate of this bug: 959946
Andreas, thanks for the work here! I assume that we have to make it common for us now to manually run this command whenever we change the API of Marionette server? So there is also no service like readthedocs out there, which would do it automatically for us?
Flags: needinfo?(ato)
(In reply to Henrik Skupin (:whimboo) from comment #18)

> Andreas, thanks for the work here! I assume that we have to make
> it common for us now to manually run this command whenever we
> change the API of Marionette server? So there is also no service
> like readthedocs out there, which would do it automatically for
> us?

See my email to tools-marionette@:

	https://groups.google.com/d/msg/mozilla.tools.marionette/aRImw7eq1IA/iaJNZzTXAwAJ
Flags: needinfo?(ato)
Depends on: 1432813
You need to log in before you can comment on or make changes to this bug.