Closed Bug 1384579 Opened 4 years ago Closed 3 years ago

Migrate buildbot linux talos machines to use generic-worker

Categories

(Taskcluster :: Workers, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1474570

People

(Reporter: kmoir, Unassigned)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → kmoir
Is the intent to migrate the existing (ix) hardware, or is this waiting until the Moonshot hardware is in place?
catlee mentioned investigating if this would be possible on existing hardware, will discuss with him today
I talked to catlee about this last week and our thinking was that given the new hardware won't be in place until late fall optimistically, I'm going to try to running it on a loaner of existing hardware and see if it works.  It I can't get it to work in a day or so, I'll try again when we have new hardware.
Neat -- I expect it should mostly "just work".  Let me know if you need a hand, e.g., with setting up scopes for the credentials you get from host-secrets.
Depends on: 1387458
Attached patch bug1384579.patchSplinter Review
preliminary patches, they don't work yet
Dragos, since you had this working in bug 1357147 I have a question. I noticed that the new (moonshot hardware) is running Ubuntu 16.04.2 LTS and the old linux ix hardware is running Ubuntu 12.04 LTS.  Is the progress to update to Ubuntu 16.04.2 LTS the same as listed here or is there a new process?

https://mana.mozilla.org/wiki/display/DC/How+To+Reimage+Releng+iX+and+HP+Linux+Machines
Flags: needinfo?(dcrisan)
That process is for iX hardware. We don't have the HP hardware yet, but the idea for the first phase is that you will continue to PXE boot and install from kickseed just like we do for Ubuntu 12.04. There isn't an "update" path for the iX hardware, though, they're different graphics drivers. Everything is a fresh install.
Flags: needinfo?(dcrisan)
BTW, you can try to get this working on iX, but I'm not sure that will just work.
I was just trying to spend < 1day getting it to work, and if it doesn't wait for the new hardware.  I just wanted to see if there was an upgrade path because every time we need to add a new talos platform for Linux, which is quite frequent these days due the needs of the quantum/stylo teams
Assignee: kmoir → nobody
Product: TaskCluster → Firefox Build System
Component: Task Configuration → Generic-Worker
Product: Firefox Build System → Taskcluster
QA Contact: pmoore
Summary: migrate buildbot linux talos machines to use taskcluster-worker native engine on Linux → Migrate buildbot linux talos machines to use generic-worker
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1474570
Component: Generic-Worker → Workers
You need to log in before you can comment on or make changes to this bug.