Stylo: Minimum font size treated differently between layout.css.servo.enabled set to True vs False

RESOLVED DUPLICATE of bug 1375332

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1375332
4 months ago
4 months ago

People

(Reporter: Mark, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 months ago
THE UNEXPECTED RESULT:

The text size in the forums of AVSFORUM is different based on the setting of layout.css.servo.enabled. (I noticed it on other sites, but for the sites I visit it is most dramatic on AVSFORUM.)

EXPECTED RESULTS:

I would expect no difference in appearance between layout.css.servo.enabled being set to True vs. False.

TO REPRODUCE (starting with a brand new profile):

1. Using Nightly, create a new profile (I called mine Test_Nightly_New)

2. Shut down Nightly, launch Nightly using the new profile.

3. Navigate to http://www.avsforum.com/forum/286-latest-industry-news/

4. Open a tab and go into about:config, and set layout.css.servo.enabled to True. (For these steps, leave this about:config tab open)

5. Open a new tab, and again navigate to http://www.avsforum.com/forum/286-latest-industry-news/

6. Notice that the threads listed under the heading "Thread / Thread Starter" appear to be the same font and size between the first tab (step 3) and the third tab (step 5).

7.Go into the menu -> Options, "General" on the sidebar, and scroll down to the "Language and Appearance" section. In "Fonts & Colors" section, on the "Default font" line, at the right, click on the "Advanced" tab.

8. Change the minimum font size to 14, then click on "Ok" at the bottom of the pop-up panel.

9. Observe that now the first tab (built with layout.css.servo.enabled=False) has a much larger font for the thread list than the third tab (built with layout.css.servo.enabled=True).

10. Change the minimum font size to something huge, like 20.

11. Observe that the minimum font size is indeed being interpreted on the third tab with layout.css.servo.enabled=True because now the text is indeed larger, but that the font size on the first tab (layout.css.servo.enabled=False) is very much larger.

MY PREFERENCE:

Personally, I prefer how layout.css.servo.enabled=True (and it certainly better matches my expectations), but in any case I would have expected the font sizes to be treated the same between the two implementations.

FIREFOX VERSION AND PLATFORM:

Firefox Nightly 56.0a1 (2017-07-26) (64-bit) BuildID=20170726030207

Windows 7 Home Premium SP1 (64-bit)
(Reporter)

Comment 1

4 months ago
Created attachment 8890423 [details]
about:support text copied to clipboard
(Reporter)

Comment 2

4 months ago
Created attachment 8890424 [details]
new_profile_servo_false.GIF
(Reporter)

Comment 3

4 months ago
Created attachment 8890426 [details]
new_profile_servo_true.GIF
(Reporter)

Comment 4

4 months ago
The two .gif files are when I had set the minimum font size to 14, then took a snippet of the AVS website for both with layout.css.servo.enabled set to True (new_profile_servo_true.GIF) and False (new_profile_servo_false.GIF). Both images cover about the same amount of screen space, omitting the advertising above and to the right of the area snipped.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1375332
You need to log in before you can comment on or make changes to this bug.