Intermittent browser/extensions/formautofill/test/browser/browser_autocomplete_marked_detached_tab.js | Uncaught exception - popup should be open - timed out after 50 tries.

RESOLVED FIXED in Firefox 56

Status

()

P5
normal
RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: ralin)

Tracking

({intermittent-failure})

unspecified
mozilla57
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

(Whiteboard: [stockwell fixed:timing][form autofill:MVP])

Attachments

(1 attachment)

14 failures in 1008 pushes (0.014 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 8
* autoland: 4
* oak: 1
* mozilla-central: 1

Platform breakdown:
* windows8-64: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-07-24&endday=2017-07-30&tree=all
16 failures in 143 pushes (0.112 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 7
* autoland: 5
* mozilla-central: 4

Platform breakdown:
* windows8-64: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-07-31&endday=2017-07-31&tree=all
This new, frequent Windows intermittent suddenly stopped today...don't know why.
Whiteboard: [stockwell unknown]
60 failures in 888 pushes (0.068 failures/push) were associated with this bug in the last 7 days. 

This is the #24 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 25
* autoland: 23
* mozilla-central: 12

Platform breakdown:
* windows8-64: 60

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-07-31&endday=2017-08-06&tree=all
18 failures in 124 pushes (0.145 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 11
* mozilla-central: 4
* mozilla-inbound: 3

Platform breakdown:
* windows8-64: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-07&endday=2017-08-07&tree=all
No failures for a couple of days, but now they are quite frequent, on Windows 8/pgo and opt.

Overall, this test has been very unreliable since added in bug 1378754.

:mattn - Can you make this test more reliable?
Flags: needinfo?(MattN+bmo)
Whiteboard: [stockwell unknown] → [stockwell needswork]
25 failures in 182 pushes (0.137 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 17
* mozilla-inbound: 7
* mozilla-central: 1

Platform breakdown:
* windows8-64: 25

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-08&endday=2017-08-08&tree=all
52 failures in 156 pushes (0.333 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 24
* autoland: 23
* mozilla-central: 5

Platform breakdown:
* windows8-64: 50
* windows7-32: 1
* windows2012-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-09&endday=2017-08-09&tree=all
22 failures in 179 pushes (0.123 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 14
* autoland: 8

Platform breakdown:
* windows8-64: 22

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-10&endday=2017-08-10&tree=all
Ray was making some changes to this test in another bug so I was hoping it may fix this…
153 failures in 901 pushes (0.17 failures/push) were associated with this bug in the last 7 days. 

This is the #5 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 78
* mozilla-inbound: 58
* mozilla-central: 17

Platform breakdown:
* windows8-64: 151
* windows7-32: 1
* windows2012-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-07&endday=2017-08-13&tree=all
(Assignee)

Comment 12

a year ago
(In reply to Matthew N. [:MattN] (huge backlog; PM if requests are blocking you) from comment #10)
> Ray was making some changes to this test in another bug so I was hoping it
> may fix this…

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ac5dd1975a6ac07efcd3365e1b2470d496fcf394
It looks like the failure is still with my patch, marking this [form autofill:MVP].
Whiteboard: [stockwell needswork] → [stockwell needswork][form autofill:MVP]
15 failures in 149 pushes (0.101 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 5
* mozilla-central: 4

Platform breakdown:
* windows8-64: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-14&endday=2017-08-14&tree=all
(Assignee)

Comment 14

a year ago
Finally got the chance to test my patch...try server seems broken in the last few days. I have no idea why would be this case that only happens on Windows 8, perhaps, its native windows management is different from others. Anyway, taking this as I believe I've fixed the issue. See the try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a9f7128d42d63508e8c7eca003fb35ce72ff1692
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 16

a year ago
mozreview-review
Comment on attachment 8897695 [details]
Bug 1384779 - Fix intermittent on browser_autocomplete_marked_detached_tab.js by ensuring popup closed before window detaching.

https://reviewboard.mozilla.org/r/168978/#review174322
Attachment #8897695 - Flags: review?(lchang) → review+
(Assignee)

Comment 17

a year ago
Thanks
Keywords: checkin-needed

Comment 18

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a917b05e1a23
Fix intermittent on browser_autocomplete_marked_detached_tab.js by ensuring popup closed before window detaching. r=lchang
Keywords: checkin-needed
Flags: needinfo?(MattN+bmo)

Comment 20

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a917b05e1a23
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
37 failures in 188 pushes (0.197 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 29
* mozilla-central: 6
* mozilla-inbound: 2

Platform breakdown:
* windows8-64: 37

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-16&endday=2017-08-16&tree=all
31 failures in 194 pushes (0.16 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 16
* mozilla-inbound: 8
* mozilla-central: 7

Platform breakdown:
* windows8-64: 31

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-17&endday=2017-08-17&tree=all
(Assignee)

Comment 23

a year ago
Looks like the problem is still, reopen the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 24

a year ago
Hi gbrown,

I had a hard time finding a way to test "browser_autocomplete_marked_detached_tab.js" on try repo, but still have no clue why it only runs on other repos. Do you know how to trigger it on try? Thank you.
Flags: needinfo?(gbrown)
See Also: → bug 1391682
(In reply to Ray Lin[:ralin] from comment #24)
> I had a hard time finding a way to test
> "browser_autocomplete_marked_detached_tab.js" on try repo, but still have no
> clue why it only runs on other repos. Do you know how to trigger it on try?

It is tricky, because you have to explicitly request Windows 8 tests, and I don't think there is a way to do that with a path; I filed bug 1391682.

I think you have 2 options:

1. Run all the browser-chrome tests with:

./mach try -b do -p win64 -u mochitest-browser-chrome-e10s[Windows\ 8]

2. Manually create the proper try syntax for the path in your push. I did

hg qnew -e and added:

try: -b do -p win64 -u mochitest-browser-chrome-e10s-1[Windows 8] --try-test-paths browser-chrome:browser/extensions/formautofill/test/browser --artifact

then

hg push -f try

You can see that here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fdfd2a36df00a7b1960443954d775425fa08a649
Flags: needinfo?(gbrown)
119 failures in 949 pushes (0.125 failures/push) were associated with this bug in the last 7 days. 

This is the #11 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 60
* mozilla-inbound: 36
* mozilla-central: 23

Platform breakdown:
* windows8-64: 119

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-14&endday=2017-08-20&tree=all
oddly there were failing on mozilla-inbound until the 18th, but now we have a couple days with no failures at all- we might be in the clear
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
Whiteboard: [stockwell needswork][form autofill:MVP] → [stockwell fixed:timing][form autofill:MVP]
status-firefox56: --- → affected
Comment on attachment 8897695 [details]
Bug 1384779 - Fix intermittent on browser_autocomplete_marked_detached_tab.js by ensuring popup closed before window detaching.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1378754
[User impact if declined]: None. This is an intermittent test failure.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes, intermittent is fixed.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: test-only change
[String changes made/needed]: None
Attachment #8897695 - Flags: approval-mozilla-beta?
Comment on attachment 8897695 [details]
Bug 1384779 - Fix intermittent on browser_autocomplete_marked_detached_tab.js by ensuring popup closed before window detaching.

This can land a=test-only.
Attachment #8897695 - Flags: approval-mozilla-beta?

Comment 30

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/c825b305f34f
status-firefox56: affected → fixed
Flags: in-testsuite+
12 failures in 908 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 10
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* windows8-64-devedition: 7
* windows8-64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-21&endday=2017-08-27&tree=all
6 failures in 939 pushes (0.006 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 4
* autoland: 2

Platform breakdown:
* windows8-64-devedition: 4
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1384779&startday=2017-08-28&endday=2017-09-03&tree=all
4 failures in 718 pushes (0.006 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* try: 4

Platform breakdown:
* windows10-64: 4

For more details, see:
https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?bug=1384779&startday=2018-03-26&endday=2018-04-01&tree=trunk
You need to log in before you can comment on or make changes to this bug.