Closed Bug 1384829 Opened 3 years ago Closed 2 years ago

Crash in java.lang.IllegalArgumentException: invalid span offsets at org.mozilla.gecko.GeckoEditable$Action.newSetSpan(GeckoEditable.java)

Categories

(Firefox for Android :: Keyboards and IME, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox56 - wontfix
firefox57 + fixed
firefox58 + fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

(Keywords: crash)

Crash Data

Attachments

(4 files)

This bug was filed from the Socorro interface and is 
report bp-8dde9949-40bd-49b2-8ae0-8225e0170726.
=============================================================

Crash reports seem to indicate the crash happens when using physical keyboards; needs more investigation.
Comment on attachment 8913029 [details]
Bug 1384829 - 1. Always perform shadow text actions;

https://reviewboard.mozilla.org/r/184392/#review189764
Attachment #8913029 - Flags: review?(esawin) → review+
Comment on attachment 8913030 [details]
Bug 1384829 - 2. Add more user-friendly debugging output;

https://reviewboard.mozilla.org/r/184394/#review189768
Attachment #8913030 - Flags: review?(esawin) → review+
Comment on attachment 8913031 [details]
Bug 1384829 - 3. No longer ignore certain exceptions;

https://reviewboard.mozilla.org/r/184396/#review189770
Attachment #8913031 - Flags: review?(esawin) → review+
Comment on attachment 8913032 [details]
Bug 1384829 - 4. Add test case to testInputConnection;

https://reviewboard.mozilla.org/r/184398/#review189774
Attachment #8913032 - Flags: review?(esawin) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e2c72495a1b
1. Always perform shadow text actions; r=esawin
https://hg.mozilla.org/integration/autoland/rev/5c83f8313d0b
2. Add more user-friendly debugging output; r=esawin
https://hg.mozilla.org/integration/autoland/rev/c6a68e0e09b2
3. No longer ignore certain exceptions; r=esawin
https://hg.mozilla.org/integration/autoland/rev/f7ca10f036de
4. Add test case to testInputConnection; r=esawin
Duplicate of this bug: 1152487
Duplicate of this bug: 837379
Given the volume, I think we definitely want this on Beta. I'm almost wondering if we should keep this in mind as a dot release ride-along candidate too. >5000 crashes with this signature in the last week on Fx55.
Flags: needinfo?(nchen)
Comment on attachment 8913029 [details]
Bug 1384829 - 1. Always perform shadow text actions;

Uplift request for part 1 and part 4. (part 2 is debugging only and part 3 is riskier and not required to fix this crash)

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Possible random crashes when inputting text
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Minimal risk
[Why is the change risky/not risky?]: Patch introduces a small amount of new code but it's covered by new and existing tests.
[String changes made/needed]: None
Flags: needinfo?(nchen)
Attachment #8913029 - Flags: approval-mozilla-beta?
Comment on attachment 8913029 [details]
Bug 1384829 - 1. Always perform shadow text actions;

Fixes a top crash, beta57+
Attachment #8913029 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
We already ship 55 with this, we will let this ride the train from 57.
Could not reproduce this issue in our Beta test session today on 57.0b7.
Leaving this bug unverified until we get more crash stats information
You need to log in before you can comment on or make changes to this bug.