Stylo: Crash in alloc::oom::oom

RESOLVED DUPLICATE of bug 1383981

Status

()

Core
CSS Parsing and Computation
P1
critical
RESOLVED DUPLICATE of bug 1383981
5 months ago
5 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

56 Branch
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 affected)

Details

(crash signature)

(Reporter)

Description

5 months ago
This bug was filed from the Socorro interface and is 
report bp-0625be8a-e875-4e76-85aa-bf53b0170726.
=============================================================

There are 2 crashes in nightly 56.
Blocks: 1375906
Priority: -- → P2
OOM in StyleBuilder::build on a 64bit platform? Do we allocate a lot in that function?

I don't quite understand how this can happen...
Me neither, build allocates a single style context, and an Arc, as far as I can tell...
I can simply reproduce the OOM from this site: http://www.robohornet.org/#et=css_selectors

STR:
1. Click the RUN button on the top right side.
2. The test runner window appears and scroll down the list.
3. Tab frozen and go to watch memory usage, e.g. macOS Activity monitor/Memory.
4. Memory usage growing until OOM.
Priority: P2 → P1
That is bug 1383981.
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #4)
> That is bug 1383981.

Yes, for other cases, they are about MP4 demuxer. I think we can dupe this bug.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383981
You need to log in before you can comment on or make changes to this bug.