Build fail on OSX 10.11.6 after Bug 1368030 landed

RESOLVED FIXED in Firefox 56

Status

()

Core
WebRTC
P1
normal
Rank:
17
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: Lenzak, Assigned: dminor)

Tracking

({regression})

Trunk
mozilla56
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Created attachment 8890770 [details] [diff] [review]
Fix Build fail introduced in bug 1368030

I encountered build fail after pull the latest code.
Here is the error message.

0:33.26 In file included from /Users/jybowser/git/gecko/obj-x86_64-apple-darwin15.6.0/media/webrtc/trunk/webrtc/modules/modules_desktop_capture/Unified_mm_webrtc_modules0.mm:38:
 0:33.26 /Users/jybowser/git/gecko/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_mac.mm:429:33: error: unknown type name 'ScreenCallbackData'
 0:33.26     : screen_callback_data_(new ScreenCallbackData(this))
 0:33.26                                 ^
 0:33.30 /Users/jybowser/git/gecko/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_mac.mm:440:26: error: use of undeclared identifier 'screen_callback_data_'
 0:33.30     rtc::CritScope lock(&screen_callback_data_->crit_sect_);
 0:33.30                          ^
 0:33.35 /Users/jybowser/git/gecko/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_mac.mm:441:5: error: use of undeclared identifier 'screen_callback_data_'
 0:33.35     screen_callback_data_->capturer = nullptr;
 0:33.35     ^
 0:33.50 3 errors generated.
 0:33.52 make[5]: *** [Unified_mm_webrtc_modules0.o] Error 1
 0:33.52 make[4]: *** [media/webrtc/trunk/webrtc/modules/modules_desktop_capture/target] Error 2
 0:33.52 make[4]: *** Waiting for unfinished jobs....
 0:33.70 libfreebl3.dylib

It is introduced by this changeset.
https://hg.mozilla.org/mozilla-central/rev/baa75a499752

The patch in the attachment can fix the build fail, but I am not sure whether it is a correct fix or not since I cannot access to this Bug 1368030
(Reporter)

Updated

5 months ago
Flags: needinfo?(dminor)
(Reporter)

Updated

5 months ago
Blocks: 1368030

Comment 1

5 months ago
+1 I am seeing this issue as well.

Comment 2

5 months ago
Why didn't this break on try?
(Reporter)

Comment 3

5 months ago
The changeset add codes inside some version-dependent #ifdefs, so this build fail only present under newer OSX I think.

Our tryserver does not have latest OSX for testing, so this failure is not covered in tests.
(Reporter)

Comment 4

5 months ago
The patch in the attachment can be a temporary workaround for the build fail.

Maybe you can try it until the owner of Bug 1368030 fix this issue.
(Assignee)

Comment 5

5 months ago
Created attachment 8890914 [details] [diff] [review]
bug-1384874-fix.patch

This moves the added structure inside an #else in the #ifdef. Please test locally, I have no way of verifying if this fixes your build issue :)
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Flags: needinfo?(dminor)
Attachment #8890914 - Flags: review?(mfroman)

Updated

5 months ago
Attachment #8890914 - Flags: review?(mfroman) → review+

Comment 6

5 months ago
I verified it fixes the build on both 10.11 and 10.12.

Comment 7

5 months ago
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1aab6bb5ab4
Fix build failure on OSX 10.11.6 after Bug 1368030 landed; r=mjf
This fix for this was included in the uplift patches of bug 1368030, so calling other branches unaffected.
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → affected
status-firefox-esr52: --- → unaffected
Keywords: regression
(Assignee)

Updated

5 months ago
Rank: 17
Priority: -- → P1

Comment 9

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c1aab6bb5ab4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.