Stylo: Content added using ::after on Pontoon does not appear

RESOLVED DUPLICATE of bug 1384065

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED DUPLICATE of bug 1384065
4 months ago
4 months ago

People

(Reporter: tchevalier, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

Trunk
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 months ago
Created attachment 8890831 [details]
Today’s Nightly, stylo enabled

If you go to https://pontoon.mozilla.org/fr/ with Stylo enabled, the percent sign under "99" is not displayed.


The percent sign is added using CSS:

#heading .progress .number::after {
    content: "%";


Note: opening the Style Inspector displays the percent sign.
(Reporter)

Comment 1

4 months ago
Created attachment 8890832 [details]
Today’s Nightly, Stylo disabled
Hmmm, a "content" property set for pseudo elements is not shown in the initial page load... sounds a bit like Bug 1380368.

Hi Shing, if you still can't have a proper reduced testcase in Bug 1380368, maybe you can take a shot from here if you want.
See Also: → bug 1380368
Théo, could you please try the site on the latest nightly (buildid: 20170727162531)? It seems to me that the percentage appears correctly.
Flags: needinfo?(theo)
(Reporter)

Comment 4

4 months ago
Nightly is stuck on 20170726 on Mac, will try with tomorrow’s Nightly, keeping NI
Blocks: 1375906
Priority: -- → P2
Pretty sure this is a dupe of bug 1384065.
Tested on macOS local build, Linux and Win64 0727 Nightly builds.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(theo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1384065
You need to log in before you can comment on or make changes to this bug.