If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect vercheck.c update in 4.15 and 4.16 releases

RESOLVED FIXED in 4.17

Status

NSPR
NSPR
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: Adam Sampson, Unassigned)

Tracking

4.16
4.17

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 months ago
Created attachment 8890873 [details] [diff] [review]
comma-4.16.diff

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170613225334

Steps to reproduce:

Built and tested the NSPR 4.15 and 4.16 releases, on Linux, with GCC 7.1.0.


Actual results:

nspr/pr/tests/vercheck.c fails, because the change made as part of the release process to add the previous version to the compatible_version array left out the trailing comma that separates it from the final entry in the array. This results in the last two entries being concatenated into "4.154.16" and the test failing.

The same error happened in both the 4.15 and 4.16 releases.


Expected results:

The release process should check that the test suite passes before release.

The description of the release process (https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR/Release_process) looks like it tries to do this, but I wonder if it's actually looking at the results of the builders *before* this final change is applied...
(Reporter)

Comment 1

2 months ago
Created attachment 8890874 [details] [diff] [review]
Fix for 4.15

Updated

2 months ago
See Also: → bug 1385039

Comment 2

2 months ago
Adam, thanks for your bug report.

It seems we weren't running the NSPR tests at all...
I've filed bug 1385039, we should try that improved.

When I run the NSPR tests, I also saw test failures with the fdcach and multiwait tests, do you get those failures, too?
(See bug 1385047 and bug 1385049)
Do you see any additional test failures on the platform you are using?

Regarding this particular bug in vercheck, I'd prefer to fix it only for the future versions. If I understand correctly, the mistake was in the testing code, and shouldn't have an effect on the library code. I'd prefer not to respin the past releases to fix the test.

Updated

2 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED

Comment 3

2 months ago
https://hg.mozilla.org/projects/nspr/rev/a0c729571e27

Updated

2 months ago
Target Milestone: --- → 4.17

Updated

2 months ago
Attachment #8890873 - Flags: review+

Updated

2 months ago
Attachment #8890874 - Flags: review+
You need to log in before you can comment on or make changes to this bug.