bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

The opened submenu loose focus and is dismissed when trying to access it

ASSIGNED
Assigned to

Status

DevTools
Netmonitor
P3
minor
ASSIGNED
a year ago
a month ago

People

(Reporter: emilghitta, Assigned: Honza)

Tracking

(Blocks: 1 bug)

56 Branch

Firefox Tracking Flags

(firefox56 affected, firefox57 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8890901 [details]
screencast of issue.gif

[Affected versions]:
- latest Nightly 56.a01
- Netmonitor Launchpad v 0.0.88

[Affected platforms]:
- Windows 10 x64
- Mac OS X 10.11.6
- Ubuntu 16.04 x64

[Steps to reproduce]:
1. Start Firefox.
2. Launch a website e.g.: https://wiki.mozilla.org/Main_Page in Netmonitor Launchpad.
3. Right click on the "Method" column or any other.
4. Hover over the Timings or over the Response Headers.
5. Try to access the newly opened menu.

[Expected result]:
The options available in the newly opened menu are easily accessible.

[Actual result]:
Sometimes, the newly opened menu, looses focus and is dismissed when trying to access it.

[Regression range]:
I don't think that this is a regression.

[Additional notes]:
Please note that this issue occurs as well as for the submenu of the context menu opened by right clicking a request.

For more information regarding this issue please observe the attached screencast.
It looks like a more general issue around submenu, which will happens on other module as well.

Emil could you help check if it also happens on other devtool?
Flags: needinfo?(emil.ghitta)
(Assignee)

Comment 2

11 months ago
Created PR for the issue:
https://github.com/devtools-html/devtools-core/pull/563

Honza
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Updated

11 months ago
Depends on: 1386525
(Assignee)

Updated

11 months ago
No longer depends on: 1386525
(Reporter)

Comment 3

10 months ago
Hi Fred !

I didn't noticed this on other devtools.

Sorry for the long delay.
Flags: needinfo?(emil.ghitta)
(Assignee)

Updated

10 months ago
status-firefox57: --- → fix-optional
(Assignee)

Updated

8 months ago
status-firefox57: fix-optional → wontfix

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.