History UI slide animation got worse?

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
10 months ago
8 months ago

People

(Reporter: milan, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 10
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Click on Library, then History.  The animation for the sliding in got worse, either with 20170727100347 or a day or two preceding it.

It is particularly noticeable if you customize the toolbar with a direct link to history.  At least for me.

If you look at the first animation in this recording, it's good:
https://www.youtube.com/watch?v=ZnNQFe1L8Hc

If you look at the last one, you can see where the weird thing happens:
https://www.youtube.com/watch?v=ZnNQFe1L8Hc&t=75
Keywords: regression

Comment 1

10 months ago
Can you find a regression window? Because on the frontend side, the only relevant bug is bug 1354533 (which landed in yesterday's nightly), but so far most of the issues I've seen filed in the last few days have been related to gecko issues (cf. bug 1382918). If you can easily verify good/bad behaviour on your machine, narrowing down a regressor would really help getting this addressed.
Flags: needinfo?(milan)

Comment 3

10 months ago
(In reply to Milan Sreckovic [:milan] from comment #2)
> I have very little confidence in this regression range:
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=0faada5c2f308f101ab7c54a87b3dce80b97d0e3&tochange=7ce5
> 57b85b611536b69539a7c18d4834ffc92eea

OK, but that's significantly longer ago than the last few days. Does that seem right?
Yes, it seems to be longer than that.  Pre bug 1354533 we had a slightly different behaviour, sometimes I don't get anything in that menu, but I think the "make it full size, then go back and animate the transition" was there before that patch as well.
I'll check tomorrow given bug 1382918 comment 17, it may very well be a duplicate of that.

Comment 5

10 months ago
Given both bug 1382627 and bug 1382918 have been marked wfm/fixed, I just want to check, is this better now, too?
Flags: needinfo?(milan)
Not any better in 20170730100307, but I can check tomorrow as well.
Seems to be OK in 20170912100139.  Closing.  If it comes back, I can bisect for what fixed it.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(milan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.