we create lots of identical 236color palettes

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Win32
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: timeless, Assigned: dcone (gone))

Tracking

Trunk
mozilla1.1beta
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
GDI Leak tracking tools for w9x are available in source only form from:
http://msdn.microsoft.com/msdnmag/issues/01/03/leaks/print.asp
I'm going to attach a zip containing the compiled GDIUsage.exe and MenuUsage.exe
(compiled by kaie)

Steps, run GDIUsage, take snapshot, run mozilla, open lots of mozilla things,
click compare, click details in the compare collumn, type 'p' to jump to the
palette section, press down to see each palette in turn, focus on the 236color
palettes.

For my first test, I took a snapshot, and opened a new mozilla window, my
homepage is a randomizer, this time it took me to
http://www.jobnext.com/resources/top10interviewtips.shtml which has 3 images all
gifs. I clicked compare, details and found 3 new identical 236 color palettes.
(Reporter)

Comment 1

16 years ago
Created attachment 79998 [details]
GDIUsage.exe and MenuUsage.exe
(Reporter)

Comment 2

16 years ago
bugs in report: I'm using a recent branch build instead of the actual release or
trunk [Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020416.17].

Comment 3

16 years ago
Moving bugs to new Image: GFX component
Component: ImageLib → Image: GFX

Comment 4

16 years ago
saari?  can you comment on this?
Target Milestone: --- → mozilla1.1beta

Comment 5

16 years ago
probably, palette ownership is per image... we should create one shared palette
and just delete it when shutting down.

Comment 6

16 years ago
How much memory does each palette take up?
(Reporter)

Comment 7

16 years ago
*** Bug 146001 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
This happens in the windows image code.. can you take a look and see if this 
could be a good win?
Assignee: pavlov → dcone
(Assignee)

Comment 9

15 years ago
Each image will create it own palette.. for 8 bit images.  Has to be this way..
currently we dont even have 8 bit images so this is not an issue.  It will come
back soon... as soon as I check in my 8 bit gif change.. but the memory savings
is huge when going from 24 bit to 8 bit.  Anyway.. marking this works for me..
since this is no longer true.  
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 10

15 years ago
*** Bug 143909 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

15 years ago
Component: Image: GFX → GFX: Win32
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.