If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Default theme title bar has insufficient area for dragging on OS X

RESOLVED DUPLICATE of bug 1371769

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1371769
2 months ago
2 months ago

People

(Reporter: Augie Fackler, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Created attachment 8891008 [details]
Screen Shot 2017-07-27 at 14.23.24.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170726100322

Steps to reproduce:

1) Install Firefox Nightly
2) Have enough tabs open that the whole tab bar is full
3) Drag the window around my screen


Actual results:

There's a little tiny area right next to the Close/Minimize/Maximize buttons that I can use to drag the window. The entire rest of the title bar is given over to:
 * Rearranging existing tabs
 * Adding a new tab with the +
 * Resizing the window (vertically, horizontally, or both depending on where the click lands)


Expected results:

There should be an affordance for moving the window around between the top of the tabs and the top of the window title bar.

I've attached a screenshot of a (intentionally small for demonstration purposes) window with the only (as far as I can tell) draggable region highlighted in an ugly greenish color. The entire region to the right of the new tab button causes the window to resize.

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1371769
You need to log in before you can comment on or make changes to this bug.