Navigator.getVRDisplays() returning 0 displays

RESOLVED FIXED

Status

()

Core
WebVR
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: cmills, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I am having a problem with my WebVR tests/demo writing.

None of the WebVR 1.1 demos I wrote or the other demos I found (which were working fine previously) will now run. The problem seems to be that getVRDisplays() is returning 0 displays, even though my display is definitely connected (the SteamVR games for example run fine).

Example demos I have been trying:

https://webvr.info/samples/00-hello-webvr.html
https://mdn.github.io/webvr-tests/raw-webgl-example/

* I am running 64-bit Nightly on Windows 10.
* The hardware is a Razer Blade and an HTC VIVE

Other points already brought up:

* It is definitely 64-bit Fx I am running
* I am running it with High Performance NVIDIA processor (GPU) selected
* I have not got SteamVR running at the same time (although this never used to be a problem)
* I have also checked to make sure that Dom.vr.oculus.enabled and Dom.vr.openvr.enabled are both enabled, just in case.

Has anyone else got any ideas? I don't know what else to try.
Would you be able to try a mozregression (http://mozilla.github.io/mozregression/) to see which commit may have caused this on your machine?
Flags: needinfo?(cmills)
I don't really know enough about mozregression and the engineering process to use it effectively. I tried using the GUI by watching the video on the download site, but it isn't very helpful.

Instead, I worked out where the problem occurred in low-fi fashion — I downloaded a few builds, and worked out which one problem started to occur on. These are my results:


Builds tried

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/07/2017-07-15-03-02-06-mozilla-central/
Doesn't work - Navigator.getVRDisplays() returns zero displays

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/07/2017-07-01-03-02-03-mozilla-central/
Doesn't work - Navigator.getVRDisplays() returns zero displays

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/06/2017-06-27-03-02-09-mozilla-central/
Doesn't work - Navigator.getVRDisplays() returns zero displays

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/06/2017-06-26-03-02-09-mozilla-central/
Navigator.getVRDisplays() does return a display, and the onscreen canvas goes into presenting mode. However, it doesn't show in VR display, and the Steam VR UI always reports "(unresponsive) firefox.exe"

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/06/2017-06-25-03-02-10-mozilla-central/
Works

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/06/2017-06-23-04-54-18-mozilla-central/
Works

https://download-origin.cdn.mozilla.net/pub/firefox/nightly/2017/06/2017-06-15-03-02-08-mozilla-central/
Works
Flags: needinfo?(cmills) → needinfo?(kgilbert)
Thanks for narrowing the regression window so closely, it really helps!

I have found one change coinciding with this timeline.

Bug 1371845 landed on 2017-06-26, upgrading our OpenVR runtime to version 1.0.8.

Could you please check what version of SteamVR you are using?  If it is older than 1.0.8, then you will need to update.  Otherwise, we will need to investigate a bit deeper.

Cheers,
 - Kip
Flags: needinfo?(kgilbert) → needinfo?(cmills)
Hi Kip,

As you hinted at, I updated SteamVR, and everything started to work fine. Thanks for the help here.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(cmills)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.