Closed Bug 1385124 Opened 5 years ago Closed 5 years ago

Mobile firefox deeplinks are redirecting to alternate-app links which are not closing by themselves after redirecting to app

Categories

(Firefox for Android Graveyard :: General, defect, P2)

54 Branch
defect

Tracking

(fennec+, firefox56 wontfix, firefox57 wontfix, firefox58 fixed)

RESOLVED FIXED
Firefox 58
Tracking Status
fennec + ---
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: purnima.yadla, Assigned: jchen)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

Device: Any Android device
OS version: 4.4.2 & higher
Firefox browser version: 54.0.1

1) Go to playstore and install the Amazon music Android app
2) Sign in using a valid Amazon account
3) Open following deeplink url by copying and pasting it in firefox browser:
https://music.amazon.com/playlists/B01HZXDWGS?do=play&ref=dm_sh_ssddeerrttff0playlistplay&tag=playlistPlay&DEEPVIEWSAB_107318=T1


Actual results:

Deeplink opens a deepview which promptly redirects to an alternate-app.link url upon app detection, which then opens the Amazon music app

After going to the music app when we press back button we see a blank page.
Blank page persists until two more back button clicks after which we are taken back to the deepview


Expected results:

Deeplink opens a deepview which promptly opens the Amazon music app
Any 307 redirects that happen in between should be killed upon app detection before redirecting to app.
probably need both platform/front-end to look into this? ni snorp and nechen
Flags: needinfo?(snorp)
Flags: needinfo?(cnevinchen)
We are able to reproduce this behavior in another flow if that is helpful too. You need not have the Amazon Music app installed on Android, so just follow these steps:

1. Navigate Firefox to https://music.amazon.com/embed/B01HZXDWGS
2. Tap on the album art
3. A new tab is opened (due to target="_blank" on the link) which returns 307 redirect to app store intent URI

Expected: The new tab should close itself since it has no HTML content and is opening another app

Actual: new blank tab stays open and app store opens. Upon hitting back button, the blank tab is present and confusing.
tracking-fennec: --- → +
Flags: needinfo?(cnevinchen)
Priority: -- → P2
Jim can you see if there's something we can do?
Flags: needinfo?(snorp) → needinfo?(nchen)
Assignee: nobody → nchen
Flags: needinfo?(nchen)
Bump any update?
Looking into it
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Any updates or ETA?
You can compare with testing the above mentioned url in Chrome browser for expected behavior.
The problem mentioned in comment 0 seems to be fixed in Nightly? If I open that link, the music app opens, but if I press back, it goes back to the mobile site directly; there are no blank pages in-between.

The problem mentioned in comment 2 is still there, pressing back returns to the blank page that the target=_blank link opened.
Comment on attachment 8912893 [details]
Bug 1385124 - Close tab when new tab redirects to external app;

https://reviewboard.mozilla.org/r/184214/#review189672

LGTM.
Attachment #8912893 - Flags: review?(s.kaspari) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e019978b9d3
Close tab when new tab redirects to external app; r=sebastian
https://hg.mozilla.org/mozilla-central/rev/6e019978b9d3
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Is this something that we should nominate for Beta approval or can it ride the 58 train?
Flags: needinfo?(nchen)
Let it ride the train IMO.
Flags: needinfo?(nchen)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.