Improve Mouse Wheel preferences

VERIFIED DUPLICATE of bug 66522

Status

SeaMonkey
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 66522
16 years ago
14 years ago

People

(Reporter: Ken Harris, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041712

The layout of "by [1] lines" / "use system default" is just plain
weird.  It's hard to see that checking the checkbox dims the [1]
field, which doesn't help matters.  And some other program I saw
(IE?) had line/pages together, perhaps in a popup.  The way it is
now, it didn't even occur to me (until I started writing this bug
report) that you could scroll by pages, because it's not part of the
"scroll document by ..." option.

The modifier-key-popup scheme isn't very elegant, either.  The
default setting appears to be "scroll by system default, unless
shift is being pressed (then scroll by 1 line), or option is being
pressed (then browse through history)".  I had to select each item
of the popup to figure that out, though.  I'd like to be able to see
at a glance what the modifier-key-to-action mapping is.

Reproducible: Always
Steps to Reproduce:
1. Open preferences
2. Look at Advanced -> Mouse Wheel


Actual Results:  This panel is inelegant, and often confusing.

Expected Results:  Hmm, for the lines/pages/default, how about emphasizing that
there
are 3 basic actions (scroll, history, text size) by something like:

(*) Scroll the document
     (*) by [1 ] lines
     ( ) by pages
     ( ) by the system default
( ) Move back/forward through history
( ) Make the text bigger/smaller

No great ideas for the modifier-key-to-action mapping part yet,
but I'm optimistic a better solution exists.

Any design or usability testing done on the prefs?  I don't see
anything about mouse wheels on the mozilla.org UI/prefs page.
(Reporter)

Comment 1

16 years ago
Created attachment 80017 [details]
An alternative way to choose mousewheel actions

Things I like about mine over the existing one:

-- I can see at a glance what happens when I use the mousewheel,
with option, etc.
-- (Corollary: I can see that holding down control doesn't do anything
special)
-- All the scrolling options are together -- "by pages" isn't really
a different option than "by lines"

Things I don't really like about mine:
-- The radio buttons look awkward hanging off the right side
-- The radio buttons are only relevant for one of the options
-- "Normally", "option", "control", and "shift" are a little hard to
pick out of the noise.

Comments very welcome...

Comment 2

16 years ago
CC'ing MPT.

Comment 3

16 years ago
Confirming as an RFE with a mocked-up proposal for improvement.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mouse wheel prefs is confusing → Improve Mouse Wheel preferences

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 66522 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.