Closed Bug 1385250 Opened 4 years ago Closed 2 years ago

Label for the default value of Content process limit changed from 4(default) to 1(default), if initially dom.ipc.processCount.web=4

Categories

(Firefox :: Preferences, defect, P5)

55 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 56
Tracking Status
firefox55 - wontfix
firefox56 + wontfix
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: brindusat, Assigned: mrbkap)

References

Details

(Whiteboard: [photon-preference] [fixed by bug #1406212])

[Affected versions]: 
Beta 55.0b10

[Affected platforms]:
Platforms: Windows 10 x 64, Ubuntu 16.04 and Mac OS X 10.10

[Preconditions]
1. Open Beta with a new profile.
2. Go to about:config and search for "dom.ipc.processCount.web". If this is not 4 repeat steps 1 and 2 until the value of dom.ipc.processCount.web is 4.

[Steps to reproduce]:
1. Open Beta with a new profile.
2. Go to about:preferences#general at Performance section
3. Uncheck the "Use recommended performance settings". -> Content process limit is set to 4(default).
4. Update the content process to 2.
5. Restart browser.

Expected results:
In Preferences page, the Content process limit should be 2 and default value should remain 4(default).

Actual results:
In Preferences page, the Content process limit is 2, but the default value updated to 1(default).


Note:
The problem here is that the labeling for default value is changed from 4(default) to 1(default). The value for the Content process limit remains the one set by the user before browser restart.
Whiteboard: [photon-preference][triage]
Correct Affected version is Beta 55.0b13
[Tracking Requested - why for this release]:
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384962
This is not an exact dup. Somewhere in the code `dom.ipc.processCount.web` is deleted upon reboot when a manually set `dom.ipc.processCount` value exists.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
target to fix it in beta 56
Priority: -- → P3
Whiteboard: [photon-preference][triage] → [photon-preference]
Target Milestone: --- → Firefox 56
Too late for 55 but happy to take a fix for 56
Priority: P3 → P5
We are only 1 week from RC. Mark 56 fix-optional but still happy to have the fix in 56.
Bug 1406212 will fix this behavior on 58 branch. Leave the bug open to since it's still valid in 57/56.
Depends on: 1406212

Fixed by bug #1406212 (per comment #8), so I'm closing this one.

Assignee: nobody → mrbkap
Status: NEW → RESOLVED
Closed: 4 years ago2 years ago
QA Contact: Virtual
Resolution: --- → FIXED
Whiteboard: [photon-preference] → [photon-preference] [fixed by bug #1406212]
You need to log in before you can comment on or make changes to this bug.