RFE: an "age" column in the message list pane (similar to the date column)

VERIFIED DUPLICATE of bug 137907

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 137907
16 years ago
14 years ago

People

(Reporter: Keith Lea, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc1) Gecko/20020413
BuildID:    2002041306

I thought I had already reported this, but searching reveals nothing, so I
must've forgotten to hit Commit. Sorry if I already did submit it.

Anyway, I really have no concept of absolute time. When I see "4/19/02 6:00 AM"
it takes me a good amount of mental effort to determine when that was in
relation to my own life. Thus, I think an "age" column would be very nice.

For example, for "4/19/02 6:00 AM" (given the current time of 4/19/02 12:13 PM),
the Age column for that message would say "6 hours". For "4/17/02 6:15 PM" it
would say "3 days". For 4/3/02 it would say "2 weeks".

Here's the fun part: I can write you a C function to convert a time (unix epoch,
I would assume) into an age. Would that help get this implemented faster? If so,
I'll gladly do it.

Comment 1

16 years ago
You had already raised this as bug 137907, marking this as a duplicate.
Certainly if you can implement the feature its more likely to be done, read the
developer documentation at www.mozilla.org to find out about the various
standards in use (for internationalisation reasons there's not much done with
raw char*'s these days).

*** This bug has been marked as a duplicate of 137907 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Created attachment 83222 [details]
A cpp file that contains a function to get a string representation of a time difference

A "test suite" is at the bottom - just compile and run it in VC++ and it should
run a demo of sorts. Sorry, it uses char*'s. If you really want me to, I could
convert it to use mozilla strings, but there's so much to read and it seemed
like a developer could do it far more easily and correctly.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.