Closed Bug 1385448 Opened 5 years ago Closed 5 years ago

Tab crash after allowing camera/mic access on talky.io

Categories

(Core :: WebRTC: Audio/Video, defect)

56 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1385481

People

(Reporter: haik, Assigned: achronop)

References

Details

Mozregression led me to

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c95cc38d6065231a03f0a00234c660f4e5b5248f&tochange=5a192849567ed9c67fc099255525a1cfb54887e6

achronop@gmail.com
Thu Jul 27 09:25:17 2017 +0000	5a192849567e	Alex Chronopoulos — Bug 1384053 - Update cubeb from upstream to 09aeb59. r=kinetik

servo-vcs-sync@mozilla.com
Thu Jul 27 09:22:10 2017 +0000	0fb1f74ee338	Simon Sapin — servo: Merge #17884 - Upgrade to rustc 1.21.0-nightly (599be0d18 2017-07-26) (from servo:rustup); r=Manishearth

Of which, bug 1384053 is probably what's triggering this.

When the crash happens, this is printed to the console

Assertion failed: (info->id), function audiounit_set_device_info, file /Users/haftandilian/r/mozilla-central/media/libcubeb/src/cubeb_audiounit.cpp, line 610.
Flags: needinfo?(achronop)
The problem reproduces for me every time with today's Nightly on Mac. That's 56.0a1 (2017-07-28). I'm running a MacBook Pro (Retina, 15-inch, Mid 2015) and am using the built in camera and microphone. The problem happens on talky.io. After I click "Start a chat", I get the prompt to allow/deny camera and mic access. The crash happens immediately after clicking "Allow".
See Also: → 1384053
Summary: New tab crash after allowing camera/mic access on talky.io → Tab crash after allowing camera/mic access on talky.io
Assignee: nobody → achronop
Flags: needinfo?(achronop)
In case it helps with debugging, here's output from the crash on a debug build.

(audio_device_impl.cc:91): Create
(audio_device_buffer.cc:73): AudioDeviceBuffer::ctor
(audio_device_impl.cc:138): AudioDeviceModuleImpl
(audio_device_impl.cc:146): CheckPlatform
(audio_device_impl.cc:169): current platform is Mac
(audio_device_impl.cc:190): CreatePlatformSpecificObjects
(audio_device_impl.cc:1901): PlatformAudioLayer
(audio_device_impl.cc:359): Mac OS X Audio APIs will be utilized
(audio_device_impl.cc:396): AttachAudioBuffer
(audio_device_buffer.cc:189): SetRecordingSampleRate(48000)
(audio_device_buffer.cc:196): SetPlayoutSampleRate(48000)
(audio_device_buffer.cc:213): SetRecordingChannels(1)
(audio_device_buffer.cc:220): SetPlayoutChannels(2)
(audio_device_impl.cc:1509): RegisterEventObserver
(audio_device_impl.cc:1522): RegisterAudioCallback
(audio_device_buffer.cc:88): RegisterAudioCallback
(audio_device_impl.cc:524): Init
(audio_device_impl.cc:1253): SetPlayoutDevice(0)
(audio_device_impl.cc:573): InitSpeaker
(audio_device_impl.cc:1348): SetRecordingDevice(0)
(audio_device_impl.cc:583): InitMicrophone
(audio_device_impl.cc:1062): StereoPlayoutIsAvailable
(audio_device_impl.cc:1072): output: 1
(audio_device_impl.cc:1081): SetStereoPlayout(1)
(audio_device_buffer.cc:220): SetPlayoutChannels(2)
(audio_device_impl.cc:948): StereoRecordingIsAvailable
(audio_device_impl.cc:958): output: 1
(audio_device_impl.cc:967): SetStereoRecording(1)
(audio_device_buffer.cc:213): SetRecordingChannels(2)
[Child 61478] WARNING: Cannot query channel count on a AudioSegment with no chunks.: '!mChunks.IsEmpty()', file /Users/haftandilian/r/mozilla-central/dom/media/AudioSegment.h, line 370
Assertion failed: (info->id), function audiounit_set_device_info, file /Users/haftandilian/r/mozilla-central/media/libcubeb/src/cubeb_audiounit.cpp, line 610.
Fix pushed for review in cubeb repo: https://github.com/kinetiknz/cubeb/pull/342
Depends on: 1385481
This crash fixed in Bug 1385481
The patch on bug 1385481 works for me. Thanks for the quick fix.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385481
You need to log in before you can comment on or make changes to this bug.