can't backspace in to: field of message compose window

VERIFIED FIXED

Status

MailNews Core
Composition
--
critical
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Biesinger, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020419
BuildID:    2002041908

Pressing backspace in the message compose window doesn't seem to have an effect
(ie. no character is deleted)

it works in form fields, though. also, it works in the subject field and mail body.

Reproducible: Always
Steps to Reproduce:
1.File|New|Message
2.Enter something in the To: field
3.Press backspace

Actual Results:  nothing

Expected Results:  last character should have been deleted
The delete key doesn't work either.

Comment 2

16 years ago
can you highlight and type over?
Yeah that works, sorry for not mentioning initially.
However, highlighting the text and pressing delete or backspace then doesn't
work either.
Every character I type in the To: field I get the following JS strict warning
appearing 4X:

JavaScript strict warning: 
chrome://messenger/content/messengercompose/MsgComposeCommands.js line 831:
reference to undefined property
Components.classes['@mozilla.org/autocompleteSession;1?type=ldap']

Not sure if that is related or not.

As a workaround to completely clear the field, you can select and cut the text...

Comment 5

16 years ago
I'd have to say mine is the most likely checkin from last night for this.  Is 
this showing up on any platforms other than Linux?  My Mac and Windows trees are 
from middle of the night and they don't exhibit any problems.  My Linux tree 
shows it but that from later in the night.

Comment 6

16 years ago
The assert looks like it's being triggered by ldap autocomplete, and is probably
not related.  My guess is you should probably file a separate bug for that so it
gets looked at by an autocomplete person.

Comment 7

16 years ago
isn't it possible that auto-complete is hanging up the ability to delete
characters? I'm marking this a smoketest blocker.
Severity: normal → blocker
Keywords: smoketest

Comment 8

16 years ago
Oh, this is only in the To field, not in the content area?  (Sorry, I missed
that the first time).  Sure enough, I see this in the To field and not in the
content area.  I don't see the ldap assertions, but I don't have any local ldap
server here.

Curiously, ctrl-H works fine for backspacing; it's just the backspace key that
doesn't work in the To field.  I know joki is looking at it but I don't see his
name on the cc, so I'm adding him.  In the subject and content areas, both
ctrl-H and backspace work.

Comment 9

16 years ago
is ctl-h enough of a workaround to not keep the tree closed?

Comment 10

16 years ago
WinXP - 2002041903 Works For Me

Comment 11

16 years ago
most users don't know about ctrl-h

Comment 12

16 years ago
autocomplete (on or off) doesn't affect this bug, so it's likely unrelated (just
like akk said).

I think a lot of linux users know what ctl-H does, but probably not enough to
let this slide.

Comment 13

16 years ago
this is pretty bad, but not technically a blocker; joki's working on it
diligently, and that's good enough for me to get the tree open.
Severity: blocker → critical
Keywords: smoketest

Comment 14

16 years ago
i believe this should be fixed now due to the backout of joki's checkin
yesterday for bug 124990.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

15 years ago
verified with 8-23-2002 branch builds during bft testing on winxp, mac and linux
and confirmed again with 20011121 trunk builds on winxp, mac and linux
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.