[Photon] Update sidebar styling for dark theme

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
8 months ago

People

(Reporter: nhnt11, Assigned: ntim)

Tracking

(Depends on 2 bugs)

Trunk
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 wontfix, firefox57 wontfix, firefox64 verified)

Details

(Whiteboard: [reserve-photon-visual][p3][ntim-intern-project])

Attachments

(3 attachments)

Reporter

Description

2 years ago
Background should be dark.
Whiteboard: [photon-visual] → [photon-visual] [triage]
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual][p3]
Flags: qe-verify+
Priority: -- → P3
QA Contact: brindusa.tot
Priority: P3 → P4
Duplicate of this bug: 1390410
Duplicate of this bug: 1394064
See Also: → 1408121
Duplicate of this bug: 1409108
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Priority: P4 → P1
See Also: → 1365807
Assignee

Updated

2 years ago
Blocks: 1418602
Comment hidden (mozreview-request)
Duplicate of this bug: 1432723
Assignee: jaws → nobody
Status: ASSIGNED → NEW

Comment 7

a year ago
mozreview-review
Comment on attachment 8919591 [details]
Bug 1385518 - (WIP) Update sidebar styling for dark theme.

https://reviewboard.mozilla.org/r/190456/#review228422

::: browser/components/places/content/sidebarUtils.js:20
(Diff revision 2)
> +      document.documentElement.style.setProperty("--chrome-secondary-background-color", background);
> +      document.documentElement.style.setProperty("--chrome-color", color);
> +      document.documentElement.setAttribute("compacttheme", "true");

Note that you're definitely not supposed to be dirtying the DOM inside a promiseLayoutFlushed callback.

Updated

a year ago
Duplicate of this bug: 1440447
Assignee: nobody → stokesdy
Assignee

Updated

a year ago
Assignee: stokesdy → nobody
Assignee

Comment 9

a year ago
This will be much easier to do with bug 1418602 fixed, leaving this bug on hold for now.
No longer blocks: 1418602
Depends on: 1418602
Assignee

Updated

10 months ago
No longer blocks: dark-theme-darkening

Updated

10 months ago
Duplicate of this bug: 1474588
Assignee

Updated

9 months ago
Whiteboard: [reserve-photon-visual][p3] → [reserve-photon-visual][p3][ntim-intern-project]
No longer blocks: 1474588
Assignee

Comment 11

9 months ago
Now that bug 1418602 is fixed, we can simply add the sidebar/sidebar_text properties to nsBrowserGlue.js.

Although, I'm thinking it's better to get bug 1484891 and bug 1485017 fixed first, to avoid shipping a half-baked dark sidebar.
Depends on: 1484891, 1485017
Assignee

Updated

9 months ago
Assignee: nobody → ntim.bugs
Comment on attachment 9005869 [details]
Bug 1385518 - Update sidebar styling for dark theme. r=jaws

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9005869 - Flags: review+

Comment 14

9 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af2c47f0c8d7
Update sidebar styling for dark theme. r=jaws
https://hg.mozilla.org/mozilla-central/rev/af2c47f0c8d7
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Depends on: 1488779
Assignee

Updated

9 months ago
Depends on: 1485599
Assignee

Updated

9 months ago
Depends on: 1489485
Assignee

Updated

9 months ago
Depends on: 1489495
I have reproduced this bug with Nightly 56.0a1 (2017-07-28) on Windows 10, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID   - 20180910220142
User Agent - Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64

QA Whiteboard: [bugday-20180905]
Assignee

Comment 17

8 months ago
Hi Amy, would it be possible to get a quick UI-review of the dark theme sidebar (bookmarks/history/synced tabs) during the 64 cycle ? This is already in Nightly.

Thank you.
Flags: needinfo?(amlee)
Assignee

Updated

8 months ago
Depends on: 1491688
(In reply to Tim Nguyen :ntim (please use needinfo?) from comment #17)
> Hi Amy, would it be possible to get a quick UI-review of the dark theme
> sidebar (bookmarks/history/synced tabs) during the 64 cycle ? This is
> already in Nightly.
> 
> Thank you.

Hi, 

Took a quick look and there are some edits I'd like to make. Will post them once I make my notes
Flags: needinfo?(amlee)
Hi, 

Please see below for the CSS for the dark them side bar. Thanks!

https://firefoxux.github.io/people/amlee/Dark-Theme-Sidebar
Assignee

Comment 20

8 months ago
(In reply to Amy Lee [:amylee] UX from comment #19)
> Hi, 
> 
> Please see below for the CSS for the dark them side bar. Thanks!
> 
> https://firefoxux.github.io/people/amlee/Dark-Theme-Sidebar

Thanks! I'll file bugs for individual items.
Assignee

Updated

8 months ago
Depends on: 1493776
Assignee

Updated

8 months ago
Depends on: 1493789
Build ID 	20181001100147
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Verified this bug on latest Nightly 64.0a1 on Windows 10 x64 and Mac OS X 10.13 and the background color for the Dark theme is grey, not black. Please see the attachment. Is this the expected color for background on the sidebars?
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(amlee)
Yes this is correct. Thanks!
Flags: needinfo?(amlee)

Updated

8 months ago
Depends on: 1495442
Assignee

Comment 23

8 months ago
Yes, that's correct!
Flags: needinfo?(ntim.bugs)
Assignee

Updated

8 months ago
No longer depends on: 1495442
Verified on Ubuntu 16.04 with latest Nightly 64.01 (10.02.2018) and the bug is fixed, the background color for sidebars is dark grey when using the Dark theme.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.