Closed Bug 1385537 Opened 3 years ago Closed 3 years ago

do_relocation_section incorrectly checks for writable segments

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: heycam, Assigned: glandium)

References

Details

Attachments

(1 file)

Just saw this compiler warning go past.
Duplicate of this bug: 1385703
Comment on attachment 8891602 [details]
Bug 1385537 - Check for writable segments correctly.

https://reviewboard.mozilla.org/r/162710/#review168160

Note that we have a problem in how we handle host cflags, because they don't include warning flags :(
Attachment #8891602 - Flags: review?(mh+mozilla) → review+
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/799a8785eab1
Check for writable segments correctly. r=glandium
https://hg.mozilla.org/mozilla-central/rev/799a8785eab1
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Assignee: nobody → mh+mozilla
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.