The autofocus attribute on <input> or <textarea> causes a delay in applying external style sheets.

RESOLVED DUPLICATE of bug 712130

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 712130
6 months ago
4 months ago

People

(Reporter: John Jago, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Created attachment 8891677 [details]
autofocus-bug.webm

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122310

Steps to reproduce:

1. Create an HTML file with an <input> or <textarea> element.
2. Add the autofocus attribute to the <input> or <textarea>.
3. Apply some styles in an external style sheet.
4. Upload the HTML file and style sheet to a server.
5. Press F5.

Note: I could not reproduce this locally. It only happens when I upload the files to a DigitalOcean server (Ubuntu 14.04 + Apache) and access them with Firefox. Chromium does not have this issue.


Actual results:

The page will momentarily have no styles.


Expected results:

The styles should be applied without delay.

Updated

6 months ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

Updated

4 months ago
Priority: -- → P3

Updated

4 months ago
Duplicate of this bug: 1401365

Updated

4 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712130
You need to log in before you can comment on or make changes to this bug.