Intermittent buildfailure AttributeError: 'NoneType' object has no attribute 'status_code'

RESOLVED FIXED in Firefox 56

Status

defect
P5
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: intermittent-bug-filer, Assigned: glandium)

Tracking

(Blocks 1 bug, {intermittent-failure})

unspecified
mozilla57
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=119183085&repo=autoland

https://queue.taskcluster.net/v1/task/ZhMR2vTcSDKtbmT844EU1Q/runs/0/artifacts/public/logs/live_backing.log

[task 2017-07-29T04:02:16.371095Z] 04:02:16     INFO -   0:02.07 Downloading to temporary location /home/worker/.mozbuild/toolchains/65bebcf94fc66ea618c58c9ac33f0f206095ecfe3931cc6edb301f4b40480e3b44b0f39aea7a25fed8eef47e63523e7e670082947a3662cdc04c68ebbe5dfc89
[task 2017-07-29T04:02:16.849671Z] 04:02:16     INFO -   0:02.55 Downloading... 0.0 %
[task 2017-07-29T04:02:16.926815Z] 04:02:16     INFO -   0:02.62 Downloading... 5.0 %
[task 2017-07-29T04:02:17.021535Z] 04:02:17     INFO -   0:02.72 Downloading... 10.0 %
[task 2017-07-29T04:02:17.151766Z] 04:02:17     INFO -   0:02.85 Downloading... 15.0 %
[task 2017-07-29T04:02:17.193473Z] 04:02:17     INFO -  Error running mach:
[task 2017-07-29T04:02:17.193773Z] 04:02:17     INFO -      ['artifact', 'toolchain', '-v', '--retry', '4', '--tooltool-manifest', '/home/worker/workspace/build/src/browser/config/tooltool-manifests/linux64/releng.manifest', '--artifact-manifest', '/home/worker/workspace/build/src/toolchains.json', '--tooltool-url', 'http://relengapi/tooltool/', 'public/build/clang.tar.xz@DTBcGwBzT4-SfDBQipVrfw', 'public/build/gcc.tar.xz@a6BdC435RBC1r0iuovMF4g', 'public/build/sccache2.tar.xz@PvKml3MUQTWYVczqyXdleQ']
[task 2017-07-29T04:02:17.193888Z] 04:02:17     INFO -  The error occurred in the implementation of the invoked mach command.
[task 2017-07-29T04:02:17.194090Z] 04:02:17     INFO -  This should never occur and is likely a bug in the implementation of that
[task 2017-07-29T04:02:17.194269Z] 04:02:17     INFO -  command. Consider filing a bug for this issue.
[task 2017-07-29T04:02:17.194468Z] 04:02:17     INFO -  If filing a bug, please include the full output of mach, including this error
[task 2017-07-29T04:02:17.194634Z] 04:02:17     INFO -  message.
[task 2017-07-29T04:02:17.194843Z] 04:02:17     INFO -  The details of the failure are as follows:
[task 2017-07-29T04:02:17.195033Z] 04:02:17     INFO -  AttributeError: 'NoneType' object has no attribute 'status_code'
[task 2017-07-29T04:02:17.195250Z] 04:02:17     INFO -    File "/home/worker/workspace/build/src/python/mozbuild/mozbuild/mach_commands.py", line 1936, in artifact_toolchain
[task 2017-07-29T04:02:17.195413Z] 04:02:17     INFO -      status = e.response.status_code
[task 2017-07-29T04:02:17.206738Z] 04:02:17    ERROR - Return code: 1
[task 2017-07-29T04:02:17.206984Z] 04:02:17    ERROR - 1 not in success codes: [0]
[task 2017-07-29T04:02:17.207192Z] 04:02:17  WARNING - setting return code to 2
[task 2017-07-29T04:02:17.207565Z] 04:02:17    FATAL - Halting on failure while running ['/usr/bin/python2.7', '-u', '/home/worker/workspace/build/src/mach', 'artifact', 'toolchain', '-v', '--retry', '4', '--tooltool-manifest', '/home/worker/workspace/build/src/browser/config/tooltool-manifests/linux64/releng.manifest', '--artifact-manifest', '/home/worker/workspace/build/src/toolchains.json', '--tooltool-url', 'http://relengapi/tooltool/', 'public/build/clang.tar.xz@DTBcGwBzT4-SfDBQipVrfw', 'public/build/gcc.tar.xz@a6BdC435RBC1r0iuovMF4g', 'public/build/sccache2.tar.xz@PvKml3MUQTWYVczqyXdleQ']
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
This is a bug in `mach artifact`, which is part of the Build Config component.
Component: General Automation → Build Config
Product: Release Engineering → Core
QA Contact: catlee
Assignee

Comment 5

2 years ago
This is caused by the change in bug 1364650
Blocks: 1364650
Assignee

Comment 6

2 years ago
In fact, what this is is, the exact same root cause as bug 1364650 causes a different error because the change in bug 1364650 was incomplete.
Assignee

Updated

2 years ago
Assignee: nobody → mh+mozilla

Comment 8

2 years ago
mozreview-review
Comment on attachment 8898552 [details]
Bug 1385621 - Fix `mach artifact toolchain` handling of download exceptions after bug 1364650.

https://reviewboard.mozilla.org/r/169924/#review175152
Attachment #8898552 - Flags: review?(gps) → review+

Comment 9

2 years ago
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/7a8a4c80a43d
Fix `mach artifact toolchain` handling of download exceptions after bug 1364650. r=gps

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7a8a4c80a43d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Comment hidden (Intermittent Failures Robot)

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.