Can't add new contact to address book

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Johannes Schmid, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When pressing "OK" in the "New card" window, nothing happens.

Steps to reproduce with rc1, winxp:
1. Start mozilla,
2. go to "mail & newsgroups",
3. click "Compose" in toolbar,
4. click "Address" in toolbar,
5. click "New...",
6. enter first name "foo",
7. enter last name "bar",
8. enter email "bar@foo.com",
9. click "OK"
10. nothing happens :)

Comment 1

16 years ago
Please specify what build you are using (is it a Mozilla nightly build, a
Mozilla Milestone build)? 
(Reporter)

Comment 2

16 years ago
I'm using mozilla 1.0 RC 1
(Reporter)

Comment 3

16 years ago
I found the problem: you have to fill in the "Add to:" drop down in the "New
Card" dialog (it is empty by default) to solve the problem. As long as the
dropdown is empty, clicking "OK" has no effect.

A good solution would be selecting "Personal Address Book" by default. If you
don't want to do this, a nice error message would be ok, too ("please select an
address book first").

BTW: Just tested it with Mozilla 1.0 RC2 (that's when I found out that there is
an "Add to:" dropdown I didn't notice before).

Comment 4

16 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
Build: 2002053012

Problem still exists, this bug should be changed to NEW....

Comment 5

16 years ago
*** Bug 137133 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
hweinstein@iname.com: I'm having the same problem as well.  When I first
migrated from Netscape 4.79 I had no problems, now (a few weeks later), when I
press the "new card" button, I get a popup with "add to:" and a pull-down list
of address books to add to.  I choose an address book and press OK, and it just
returns silently, no error, no dialog.

Comment 7

15 years ago
Since I submitted this bug, I imported some addresses which were exported from
another Mozilla session.  Since I've done that, adding new address to my address
book using the "new card" button works fine.

Comment 8

15 years ago
I've verified this problem in version 1.3 running on windows 2000 and 98.  But
in my case, it happens only when I use the pt-br (Brazilian portuguese) language
pack.  When I don't use this language pack it works ok.  Any idea if this
problem is only in the language pack?
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey
WFM on Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8a6) Gecko/20041231.

The Add to drop down now defaults to Personal Address Book (I believe it was
changed at some stage), therefore the reported error sequence now works fine.

Leaving open until someone can test on Windows XP.
(Reporter)

Comment 11

13 years ago
works fine now (tested with mozilla 1.7.3 on Windows XP)
Re-tests and reporter have now shown that this bug is ok, closing as Works For Me.

Please re-open with reasons why if you think this bug should still be open.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
verified wfm with build 2005-07-10-05, Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.