Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
7 months ago
7 months ago

People

(Reporter: Hadmut Danisch, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122310

Steps to reproduce:

Having a big mailbox with about two or three thousand mails, having to read them and to sort them into different folders. 


Actual results:

Thunderbird is extremely cumbersome and annoying. Moving Mails into mailboxes requires a lot of complicated and precise mouse movements, beeing exhaustive, wasting time, causing severe ache through the Repetitive Strain Injury Syndrome. 

Thunderbird had a much better GUI interface some years ago, but with the rework it became worse and more complicated.


Expected results:

1. Rebuild the ability (that once existed) to mark multiple selected messages as Junk. 

2. Allow to add configurable buttons to the mail view window, which allow to directly move messages into configured mail folders, i.e. allow direct action through simple mouse click without complicated mouse movements over folder structurs or four hierachies of context menus.
(In reply to Hadmut Danisch from comment #0)
> 1. Rebuild the ability (that once existed) to mark multiple selected
> messages as Junk. 

Selecting multiple messages and then right click on them and use "Mark > As Junk" works for me.

> 2. Allow to add configurable buttons to the mail view window, which allow to
> directly move messages into configured mail folders, i.e. allow direct
> action through simple mouse click without complicated mouse movements over
> folder structurs or four hierachies of context menus.

I think there exists extension where you can add custom buttons. But also here right click is your friend: "Move To > ...". There is also a recent menu in it which makes it faster to find the latest used folders.

A problem of too many buttons is that we have only a limited space to show them.

Comment 2

7 months ago
#1 exists

#2 There are a number of addons. https://addons.mozilla.org/en-us/thunderbird/addon/quickfolders-tabbed-folders/ stands out

This swiss army knife for toolbar is https://addons.mozilla.org/en-US/thunderbird/addon/toolbar-buttons/?src=ss
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.