[Suggestion] Downloads panel new features

RESOLVED DUPLICATE of bug 1270405

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1270405
a year ago
a year ago

People

(Reporter: florianguillot, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170729100254




Expected results:

Review the downloads page, with the ability to create waiting lists, display flow charts, file downloads by progress, speed, etc.

Separate in four tabs downloads: In progress, finished, failed, Everything.

Especially put an option open the window of downloads in progress when Firefox closes, to avoid (as I often happen) to close Firefox and lose my current downloads.

Finally, an option to choose if Download opens in a new window or in a new tab.

Updated

a year ago
Severity: normal → enhancement
Component: Untriaged → Downloads Panel

Comment 1

a year ago
We have a long-term project to redesign some of the download-related user interface, tracked in bug 1270405. Some of the improvements include the features outlined here, other features like charts are more likely to implemented as add-ons, but I'm linking this bug to the other one so it can be referenced.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270405
You need to log in before you can comment on or make changes to this bug.