Port bug 1336531 to SM: <br>-Tag before signatures

RESOLVED FIXED in seamonkey2.54

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

unspecified
seamonkey2.54

SeaMonkey Tracking Flags

(seamonkey2.48 wontfix, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 fixed, seamonkey2.54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
+++ This bug was initially created as a clone of Bug #1336531 +++

In bug 1336531 I changed composition to not include an additional <p> before a signature.

The necessary mailnews changes were done with |#ifdef MOZ_THUNDERBIRD|.

We should eventually remove that and port the changes to SM.

I think all you need are these two hunks:
https://hg.mozilla.org/comm-central/rev/a25600ed9d2e#l1.78
https://hg.mozilla.org/comm-central/rev/a25600ed9d2e#l1.96

With those in place, we can lose:
https://hg.mozilla.org/comm-central/rev/a25600ed9d2e#l3.12
https://hg.mozilla.org/comm-central/rev/a25600ed9d2e#l3.24
https://hg.mozilla.org/comm-central/rev/a25600ed9d2e#l3.46
(Assignee)

Comment 1

a year ago
Created attachment 8891820 [details] [diff] [review]
1385725-sm.patch

Here is what I think you should do. I won't compile or test it, so please take the necessary action.
Flags: needinfo?(frgrahl)
Thanks jorg,

I will try it out. 

I was just able to reproduce my problem with the swallowed blanks and it has nothing to do with signatures. Can reproduce it 100% with newsgroup replies and in TB Daily too :) Stay tuned for a new bug but not today.
(Assignee)

Comment 3

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #2)
> Stay tuned for a new bug but not today.
I can't wait to see it ;-)
(Assignee)

Comment 4

a year ago
Comment on attachment 8891820 [details] [diff] [review]
1385725-sm.patch

No action here?
Attachment #8891820 - Flags: review?(frgrahl)
Sorry still had NI set to look into it but something always came up. Will see that I put it on top of my list.
Comment on attachment 8891820 [details] [diff] [review]
1385725-sm.patch

Works great thanks. I was able to confirm the wrong behaviour in SeaMonkey. Looking at the generated eml messages before and after the patch I can now see that the <br> is gone. Let me know if you want to check it in yourself.
 
[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Visual glitch in output message
Testing completed (on m-c, etc.): c-r
Risk to taking this patch (and alternatives if risky): none already in TB
String changes made by this patch: --
Flags: needinfo?(frgrahl)
Attachment #8891820 - Flags: review?(frgrahl)
Attachment #8891820 - Flags: review+
Attachment #8891820 - Flags: approval-comm-release?
Attachment #8891820 - Flags: approval-comm-esr52?
Attachment #8891820 - Flags: approval-comm-beta?
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
status-seamonkey2.48: --- → wontfix
status-seamonkey2.49esr: --- → affected
status-seamonkey2.50: --- → wontfix
status-seamonkey2.51: --- → wontfix
status-seamonkey2.52: --- → wontfix
status-seamonkey2.53: --- → affected
status-seamonkey2.54: --- → affected
(Assignee)

Comment 7

a year ago
https://hg.mozilla.org/comm-central/rev/0c4221f192584abffbb1d674eb309f90db25898f
Port bug 1336531 to SM: No <br>-Tag before signatures in paragraph mode. r=frg

Yes, I wanted to check it in myself. I assume you handle the approvals and uplifts. Due to the mailnews hunk, uplifts will trigger builds, so use DONTBUILD where appropriate.
(Assignee)

Comment 8

a year ago
Never got closed.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-seamonkey2.54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.54
Upps and should probably be put into the next 2.49 too. IanN could you do the a+ for 2.53 and 2.49 if ok.
Flags: needinfo?(iann_bugzilla)
Attachment #8891820 - Flags: approval-comm-beta?

Comment 10

a year ago
Comment on attachment 8891820 [details] [diff] [review]
1385725-sm.patch

a=me
Flags: needinfo?(iann_bugzilla)
Attachment #8891820 - Flags: approval-comm-release?
Attachment #8891820 - Flags: approval-comm-release+
Attachment #8891820 - Flags: approval-comm-esr52?
Attachment #8891820 - Flags: approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.