[webRequest] Cannot set listeners to requests to search engines

RESOLVED DUPLICATE of bug 1384204

Status

()

Toolkit
WebExtensions: Request Handling
RESOLVED DUPLICATE of bug 1384204
10 months ago
9 months ago

People

(Reporter: Alex, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8891931 [details]
firefox-proxy-bug.zip

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

Hi

1. Launch extension from the attachment.
2. Open developer console
3. Open new tab and start typing in address bar or input field to the right.


Actual results:

You will see that requests to 'http://SEARCH-ENGINE.com' go through PAC, but do not fire onBeforeSendHeaders and onCompleted listeners


Expected results:

they should fire these listeners

Updated

10 months ago
Component: Untriaged → WebExtensions: Request Handling
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384204
You need to log in before you can comment on or make changes to this bug.