Support wider layout to load more than 6 top sites or 3 stories / highlights

VERIFIED FIXED in Firefox 60

Status

()

enhancement
P2
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: anoopsinghrathaur2, Assigned: rrosario)

Tracking

(Depends on 1 bug, Blocks 3 bugs)

56 Branch
Firefox 60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox60 verified)

Details

(Whiteboard: [AS60MVP])

Attachments

(1 attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170730100307

Steps to reproduce:

Just open new tab 


Actual results:

Give us the ability to customized the "top sites" in activity stream like adding any website in it and load more news item on it there is only 3 item on screen utilize full screen because both side too much space is left blank.
Component: Untriaged → Activity Streams: Newtab

Updated

2 years ago
Summary: Activity Stream → Allow adding and editing top sites
Reporter

Comment 1

2 years ago
Not  just adding and editing, can you show more topic on same tab without opening pocket website like Microsoft edge is doing.

Comment 2

2 years ago
Well, we need the bug to focus on a single issue, and the add/edit will be tracked somewhere under the metabug https://github.com/mozilla/activity-stream/issues/2773

I'll morph this to loading more news items as I don't think that's being tracked.
Summary: Allow adding and editing top sites → Allow loading more news stories than the 3 to use more available space
Priority: -- → P5
Priority: P5 → P3

Comment 3

a year ago
https://mozilla.invisionapp.com/share/599XJPCC8#/screens/214057961_New_Tab_Responsive
Summary: Allow loading more news stories than the 3 to use more available space → Support wider layout to load more than 6 top sites or 3 stories / highlights

Updated

a year ago
Duplicate of this bug: 1424788

Updated

a year ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Iteration: --- → 60.3 - Feb 26
Ever confirmed: true
Priority: P3 → P2
Whiteboard: [AS60MVP]
Assignee: nobody → rrosario
After considering a few different options (see https://rlr.github.io/newtab-grid-experiments/dist/index.html), UX decided we'll add two columns of Top Sites but the rest of the cards will get larger but remain at 3 columns.
Oops, this was in next sprint. moving up.
Iteration: 60.3 - Feb 26 → 60.2 - Feb 12

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Blocks: 1426705

Updated

a year ago
See Also: → 1437213

Updated

a year ago
Blocks: 1437659
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Firefox: 60.0a1, Build ID 20180214224814

Now, on the latest Nightly build, on a wider screen, there are 8 columns of "Top Sites" displayed and the "Recommended By Pocket" and the "Highlights" cards are larger.
If the browser window is resized or if you use a smaller screen, only 6 "Top Sites" columns are displayed and the "Recommended By Pocket" and the "Highlights" cards are smaller.
Verified on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.13.
Status: RESOLVED → VERIFIED

Updated

a year ago
Blocks: 1444980

Comment 11

a year ago
Science review: R+

Updated

a year ago
Blocks: 1452724
You need to log in before you can comment on or make changes to this bug.