All users were logged out of Bugzilla on October 13th, 2018

mozilla-build 3.0 cannot find makecab

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: vlposta, Unassigned)

Tracking

SeaMonkey 2.53 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53a1
Build ID: 20170705150214

Steps to reproduce:

I install new mozilla-build 3.0 and run "C:\mozilla-build\mozmake\mozmake.exe" -f client.mk -s configure


Actual results:

checking for Windows SDK... 0x0a00 in 'C:\Program Files (x86)\Windows Kits\10\'
checking for Universal CRT SDK... 10.0.15063.0 in 'C:\Program Files (x86)\Windows Kits\10\'
checking for the Debug Interface Access SDK... C:/PROGRA~2/MICROS~1.0/DIA SDK
checking for mt... 'C:/PROGRA~2/WI3CF2~1/10/bin/100150~1.0/x64/mt.exe'
checking whether MT is really Microsoft Manifest Tool... yes
checking for link... 'C:/PROGRA~2/MICROS~1.0/VC/bin/amd64/link.exe'
checking for makecab... not found
DEBUG: makecab: Trying makecab.exe
ERROR: Cannot find makecab
*** Fix above errors and then restart with\
               "c:/mozilla-build/mozmake/mozmake -f client.mk build"
mozmake: *** [client.mk:362: configure] Error 1


Expected results:

mozilla-build 3.0 functional with makecab.exe
If you are not using VS2017 I suggest you stay with 2.3 for the time being.

Also not sure if SDK 10.0.15063.0 is compatible. The layout changed. I recommend 10.0.14393.795 right now which I know works with both VS2015 and VS2017. If this fixes it please file a bug against core.

If you have VS2015 installed try 

ac_add_options --with-visual-studio-version=2015

in your mozconfig
(Reporter)

Comment 2

a year ago
I have VS2015 but ac_add_options --with-visual-studio-version=2015 has no effect.

I try mozilla-build 2.2.0 from https://wiki.mozilla.org/MozillaBuild
Where i can download version 2.3 please ???

But now with this error ... :-(

checking for the Leanplum SDK key... no
checking for llvm-config... not found
ERROR: Could not find LLVM/Clang installation for compiling stylo build-time
bindgen.  Please specify the 'LLVM_CONFIG' environment variable
(recommended), pass the '--with-libclang-path' and '--with-clang-path'
options to configure, or put 'llvm-config' in your PATH.  Altering your
PATH may expose 'clang' as well, potentially altering your compiler,
which may not be what you intended.
*** Fix above errors and then restart with\
               "c:/mozilla-build/mozmake/mozmake -f client.mk build"
client.mk:360: recipe for target 'configure' failed
mozmake: *** [configure] Error 1



I install C:\Program Files\LLVM\

But how to and where set (concretely) please LLVM_CONFIG or '--with-libclang-path' and '--with-clang-path' and 'llvm-config' ???

Thank You
Sorry I meant 2.2.0. 2.3.0 was a prerelease for 3.0.

Add 
ac_add_options --disable-webrender
ac_add_options --disable-stylo

to the mozconfig.
(Reporter)

Comment 4

a year ago
Thank You - build 20170802174943 64Bit with VS2015 and mozilla-build 2.2.0 now compiled successfully.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.