cache/proxy problem? win32 RC 1.0 fails to access URLs outside mozilla.org and then cached mozilla.org page as the incorrect contents.

RESOLVED DUPLICATE of bug 38488

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 38488
16 years ago
13 years ago

People

(Reporter: ISHIKAWA, Chiaki, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I fetched and installed win32 rc 1.0 using the installer.

My profile has been transformed from the one for
netscape 4.7.

But, strange thing is that, when the mozilla started,
I tried to access http://www.asahi.com
but somehow the page was not accessible.
(Very strange since I was running
Netscape 4.7 beside mozilla, and netscape could
show the pages from the above mentioned site
without problems.)

Something went wrong there, and
it seemed the mozilla decided to show the
original home page (at mozilla.org) again although
I clearly tried to acccess www.asahi.com.
(Well, the original Japanese version of netscape 4.x 
has this newspaper URL http://www.asahi.com in the
suggested (or preloaded) bookmark list and
I used it to access it. Somehow the first time I tried it in
new mozilla, it failed to access it [it looks that
the netscape.com has a web page (or many pages) where
the preloaded entry in the bookmark is directed and
then re-directed to the current correct URLs (a clever
way to keep pre-released entries in the existing
program up-to-date.). 

But in my case, the first try
to access this newspaper site failed, I tried a few other
pages in the bookmarks, and they all failed, too.

Then somehow mozilla seemed to have kept the original
mozilla home page as the incorrect result of accessing
this newspaper site.
So whenever I tried to reach this site, 
mozilla showed mozilla's default entry. I got stuck
in this incorrect showing of the mozilla home page
as the content of http://www.asahi.com.
(Mozilla no longer showed that the access to the asahi.com failed
or any other diagnostics that showed something went wrong.)



Now, after re-installing the mozilla browser,
the symptom continued.

What I did in the following seemed to cure
the problem as of now, but I think
there is a bug lurking in the cache/proxy-related code.

- Firstly, I disabled the proxy setting.
  I tried to access the followign pages.
  http://www.asahi.com
  http://www.mainichi.co.jp  (the other newspaper URL
                 which seemed to have the similar problem
                 as asahi.com. I omitted this in order
                 to simplify the bug report above.)
  The above two URLs still could not be accessed.
   Or rather mozilla shoed the mozilla home page as
   the contents of the above pages. 

- But then, at least I found now that some other
  URLs outside mozilla 
  are accessible. (So it may be a cache problem after all.)

- Figuring that mozilla may be returning incorrectly cached pages
  I cleared the disk cache and tried accessing
 
  http://www.ashai.com
  http://www.mainichi.co.jp

  This time it worked! 
  I could see the contents of the newspaper sites.

Well then I tried to enable proxy again, and then mozilla
still works. So it may be that we can rule out the proxy
out of the question. (But who knows?)

In any case, that mozilla caches its own home page contents
for the www.asahi.com and www.mainichi.co.jp 
was wrong. Either it should not do so,
or should show the access error (but why did it fail to
access the URL in the first place?)
correctly.

This error  could be a one time thing that happens
ONLY WHEN the new mozilla RC 1.0 is installed and
the old netscape profile has been transformed.
(Or that the simultaneously running
netscape 4.x, which I used to access mozilla download page
may have interfered with mozilla due to resource contention???)

I could have tried to erase mozilla completely  and re-install it to
see if the problem occurs ONLY at the initial install.
But my ISP connection is not that fast to try
fetching the mozilla files over and over, and beside
the installer doesn't seem to offer me to RE-USE the
previously fetched .xpi files for new installation.
(I would count this as another bug, but I am sure you will hear
complaint on this one from many people.)

Thank you for the great package and
hope you can iron out this and other minor glitches before
final release.


PS: I know it is difficult to
see the cause of the problem from this sketchy note
but this is the best I could come up with under
the circumstances.

PPS: I tried to use newly installed mozilla
in order to report the bug, but failed to do so.
The browser responded with "The page contains no data".
I am not sure which is to blame, the mozilla
or the bugzilla. Maybe bugzilla is overloaded with
bug reporters who have tried to use the new RC 1.0.
I am using netscape 4.7 on win98 to report this problem.
(Assignee)

Comment 1

16 years ago
Reporter: which kind of proxy do you use ? 
(Assignee)

Comment 2

16 years ago
from mail:

Dear Matti,

I am using junkbuster proxy.
----------------------------------------------------

Junkbuster is broken !
Other browsers work with junkbuster because they use only Http/1,0.
(NS.47x doesn't support Http/1.1, IE5.X use Http/1.0 by default for Proxies)

To fix this problem:
select Http/1.0 in edit\preferences\advanced\Http Networking
and after that clear your Disk Cache


PS:
To add a comment open the bug URL, add your comment in the Addtional Comments
field and select the "Commit" button.

DUPE OF BUG 38488 (Proxy:junkbuster is broken - use http/1.0 to get arround
this, marked as INVALID because junkbuster itself is broken)


*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.