Mozilla crashes when recieving a null .GIF image

RESOLVED DUPLICATE of bug 138280

Status

()

--
critical
RESOLVED DUPLICATE of bug 138280
17 years ago
17 years ago

People

(Reporter: scross, Assigned: pavlov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020419
BuildID:    2002041903

In order to prevent the log file on the company intranet from filling up with
"404" errors, I "touched" three .gif files that were being refered to by "MRTG",
an SNMP monitor, effectively creating three 0-byte images.

Now, whenever those pages are viewed, Mozilla crashes.  If necessary, I will try
to prune down the page to help.

Reproducible: Always
Steps to Reproduce:
1. Replace the three images at the bottom of the output generated by MRTG with
0-byte images.

Actual Results:  Mozilla crashed

Expected Results:  Displayed the page

Comment 1

17 years ago
It would be nice if you could cut it down...
I just tried creating a html file that references a bunch of 0 size gifs and
nothing happened.

linux trunk 2002041817

Comment 2

17 years ago
I took the sample report from the mrtg homepage and saved it locally.
Made the images reference the three empty gifs and I got no crash.
I also tried renaming the files to .png (since that's the format the actual page
uses) and also no crash.
(Reporter)

Comment 3

17 years ago
It appears to also be part of SSL.  Trimmed down page is here:
<a
href="https://9bit.net/~scross/crash.html">https://9bit.net/~scross/crash.html</a>

In order to reproduce the bug, go to that page.  You may have to hit "refresh"
to get it to crash.

Comment 4

17 years ago
crashes with same stack trace as bug 138280
this testcase will be very helpful in the other bug probably

*** This bug has been marked as a duplicate of 138280 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.