Closed Bug 1386197 Opened 2 years ago Closed 2 years ago

(Mac) Opening the Bookmarks menu whilst the Library window is open causes recently bookmarked listener to remain which can impact performance

Categories

(Firefox :: Bookmarks & History, defect)

49 Branch
Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- wontfix
firefox54 --- wontfix
firefox55 --- wontfix
firefox56 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: perf, regression)

Attachments

(1 file)

I noticed this whilst having a general look at the performance of removing bookmarks.

STR:
- Open the Library window
- Set up a folder with a lot of bookmarks (e.g. ~600ish)
- Open and close the bookmarks menu
- Set up the profiler
- Delete the newly created folder.

Look at the profile -> There's lots of references to _populateRecentBookmarks and that takes a long time.

It only occurs on Mac, due to how the context menus work (Mac doesn't have context menus on the toolbar menus).

This bug was caused by bug 1248268 - it added an option for hiding or showing the recent items. However, in the Library window, the context items are not there.

As a result, attempting to deal with updating the context menu causes an exception and the listeners don't get removed.
Comment on attachment 8892406 [details]
Bug 1386197 - Show/Hide recently bookmarked menuitems don't exist in the Library window on Mac, handle the case so to avoid exceptions stopping listeners being removed.

https://reviewboard.mozilla.org/r/163356/#review168770

Good catch
Attachment #8892406 - Flags: review?(mak77) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ca999961054
Show/Hide recently bookmarked menuitems don't exist in the Library window on Mac, handle the case so to avoid exceptions stopping listeners being removed. r=mak
https://hg.mozilla.org/mozilla-central/rev/2ca999961054
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Version: unspecified → 49 Branch
You need to log in before you can comment on or make changes to this bug.