UITour wouldn't close the appMenu if running the tracking-protection's ui tour

RESOLVED DUPLICATE of bug 1382579

Status

()

RESOLVED DUPLICATE of bug 1382579
a year ago
a year ago

People

(Reporter: Fischer, Assigned: Fischer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
STR:
1. Open one private window
2. Click Tracking Protection’s “See how it works” button to enter the tracking protection introduction page.
3. Follow the instructions to arrive the state that the control center is opened and UITour’s info tooltip for the tacking-protection button (The tooltip with title of “Want to make changes”) shows.
4. Open the web console
5. Execute `Mozilla.UITour.showHighlight("addons")` in the web console
6. Make sure the addons button in the appMenu is highlighted.
7. Click the “Got it” button on the info tooltip from the step 3.
8. Make sure the control center is closed and UITour’s info tooltip disappears and the addons button's hihglight still exists.
9. Execute `Mozilla.UITour.showHighlight("backForward")` in the web console

Expected:
The highlight is switched from the addons button to the backForward button and the appMenu is closed.

Actual:
The highlight is switched from the addons button to the backForward button but the appMenu IS NOT closed.

Root Cause:
In the step 7 when hiding the info tooltip, it would trigger `hideAnnotationsForPanel` during the process. The `hideAnnotationsForPanel` would check if it was the right target[1] so that it wouldn’t accidentally close the addons button’s highlight. However, it would clear the appMenu’s `appMenuOpenForAnnotation`. As a result, in the step 9, while switching the highlight, UITour would think there is no need to close the appMenu because of no “highlight” annotation for the appMenu.


[1] https://dxr.mozilla.org/mozilla-central/rev/36f95aeb4c77f7cf3b3366583008cd6e4b6b1dba/browser/components/uitour/UITour.jsm#1481
[2] https://dxr.mozilla.org/mozilla-central/source/browser/components/uitour/UITour.jsm#1488
(Assignee)

Updated

a year ago
Assignee: nobody → fliu
(Assignee)

Comment 1

a year ago
Correct myself.
(In reply to Fischer [:Fischer] from comment #0)
> STR:
> 1. Open one private window
> 2. Click Tracking Protection’s “See how it works” button to enter the
> tracking protection introduction page.
> 3. Follow the instructions to arrive the state that the control center is
> opened and UITour’s info tooltip for the tacking-protection button (The
> tooltip with title of “Want to make changes”) shows.
> 4. Open the web console
> 5. Execute `Mozilla.UITour.showHighlight("addons")` in the web console
> 6. Make sure the addons button in the appMenu is highlighted.
> 7. Click the “Got it” button on the info tooltip from the step 3.
> 8. Make sure the control center is closed and UITour’s info tooltip
> disappears and the addons button's hihglight still exists.
> 9. Execute `Mozilla.UITour.showHighlight("backForward")` in the web console
> 
> Expected:
> The highlight is switched from the addons button to the backForward button and the appMenu is closed.
> 
> Actual:
> The highlight is switched from the addons button to the backForward button but the appMenu IS NOT closed.
> 
> Root Cause:
> In the step 7 when hiding the info tooltip, it would trigger `hideAnnotationsForPanel` during the process.
> The `hideAnnotationsForPanel` would check if it was the right target[1]
> so that it wouldn’t accidentally close the addons button’s highlight. 
   However, it would clear the appMenu’s `appMenuOpenForAnnotation`[2].
> As a result, in the step 9, while switching the
> highlight, UITour would think there is no need to close the appMenu because
> of no “highlight” annotation for the appMenu.
> 
> 
> [1]
> https://dxr.mozilla.org/mozilla-central/rev/36f95aeb4c77f7cf3b3366583008cd6e4b6b1dba/browser/components/uitour/UITour.jsm#1481
   [2] https://dxr.mozilla.org/mozilla-central/rev/ef9a0f01e4f68214f0ff8f4631783b8a0e075a82/browser/components/uitour/UITour.jsm#1482
(Assignee)

Comment 2

a year ago
The bug 1382579 handled this bug together so duplicate it
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382579
You need to log in before you can comment on or make changes to this bug.