Closed Bug 1386270 Opened 2 years ago Closed 2 years ago

Crash in mozilla::layers::WebRenderImageData::~WebRenderImageData

Categories

(Core :: Graphics: WebRender, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1383212
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-56a0a99c-90a5-4fdf-9bdf-eccee0170725.
=============================================================

Seen while looking at nightly data - crashes started using 20170724030204: http://bit.ly/2vjHYzV

So far 9 crashes/8 installs on Win 10.

Possibly another regression from Bug 1376855?
Probably, yeah. Morris, can you take a look?
Blocks: 1376855
Flags: needinfo?(mtseng)
Might the same problem with bug 1383212. The WebRenderLayerManager is dangling pointer. I'll keep track this once bug 1383212 is landed.
Assignee: nobody → mtseng
Flags: needinfo?(mtseng)
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [wr-mvp]
Target Milestone: --- → mozilla57
Looks like this has been fixed by bug1383212.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383212
Assignee: mtseng → nobody
Priority: P1 → --
Whiteboard: [wr-mvp]
Target Milestone: mozilla57 → ---
You need to log in before you can comment on or make changes to this bug.