Esc key should close element properties dialog.

VERIFIED FIXED

Status

SeaMonkey
UI Design
--
minor
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Martin Cron, Assigned: Stephen Walker)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

860 bytes, patch
jag (Peter Annema)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
It's just a little thing, but I think that things would be improved if the Esc 
key should close the element properties dialog.

When I do web development, I frequently like to know the size of an image. It's 
great that you can right-click on it and get it's size, but I expect the dialog 
to go away if I press the escape key.
-> XP APPS
Assignee: Matti → blaker
Severity: minor → enhancement
Component: Browser-General → XP Apps: GUI Features
QA Contact: imajes-qa → paw

Comment 2

16 years ago
see similar bug 135945

Can't find a dupe, confirmed on Linux cvs today...
Severity: enhancement → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
OS: Windows 2000 → All

Comment 3

16 years ago
-> sicking
Assignee: blaker → sicking
(Assignee)

Comment 4

16 years ago
Created attachment 83835 [details] [diff] [review]
patch
r=sicking, but get someone from the navigator team to sr this
(Assignee)

Comment 6

16 years ago
-> me
Assignee: sicking → walk84

Comment 7

16 years ago
Would it be better to turn this into a <dialog>? You'd get all the right dialog
key functionality for free then.

Comment 8

15 years ago
*** Bug 186794 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
It's not going to be turned into a dialog.  There was another bug report, long
ago, that discussed that.  It was agreed that it was an info window and not a
dialog box.

Does the patch still work?
(Assignee)

Comment 10

15 years ago
Neil, yes.

Comment 11

15 years ago
Have you sent an email to the browser super reviewers yet?
<http://www.mozilla.org/hacking/reviewers.html>

mailto:alecf@netscape.com?cc=blaker@netscape.com&cc=jaggernaut@netscape.com&cc=reviewers@mozilla.org
(Assignee)

Comment 12

15 years ago
Comment on attachment 83835 [details] [diff] [review]
patch

Neil, do you have a bug# for the discussion?

jag/bz, can you r/sr?
Attachment #83835 - Flags: superreview?(bzbarsky)
Attachment #83835 - Flags: review?(jaggernaut)
Attachment #83835 - Flags: superreview?(bzbarsky) → superreview+

Comment 13

15 years ago
I believe this is it:
http://bugzilla.mozilla.org/show_bug.cgi?id=101910#c28

Comment 14

15 years ago
Comment on attachment 83835 [details] [diff] [review]
patch

r=jag
Attachment #83835 - Flags: review?(jaggernaut) → review+
(Assignee)

Comment 15

15 years ago
-> fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 16

15 years ago
Verified fixed in 2003011405/WinNT, /WinXP, /Win98se
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.