Marionette's test_window_minimize.py times out in headless mode on Mac

VERIFIED DUPLICATE of bug 1384763

Status

()

VERIFIED DUPLICATE of bug 1384763
a year ago
a year ago

People

(Reporter: myk, Unassigned)

Tracking

47 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8892568 [details]
gecko.log

Marionette's test_window_minimize.py test script times out consistently when I run it locally in headless mode on Mac.  The two specific tests that time out are TestWindowMinimize.test_minimize_stress and TestWindowMinimize.test_minimize_twice_restores:

$ MOZ_HEADLESS=1 ./mach marionette-test ./testing/marionette/harness/marionette_harness/tests/unit/test_window_minimize.py
warning: ./mach marionette-test is deprecated; please use ./mach marionette test
 0:00.00 LOG: MainThread INFO Using workspace for temporary data: "/Users/myk/Projects/gecko"
 0:00.00 LOG: MainThread mozversion INFO application_buildid: 20170801094618
 0:00.00 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:00.00 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
 0:00.00 LOG: MainThread mozversion INFO application_name: Firefox
 0:00.00 LOG: MainThread mozversion INFO application_remotingname: firefox
 0:00.00 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:00.00 LOG: MainThread mozversion INFO application_version: 56.0a1
 0:00.00 LOG: MainThread mozversion INFO platform_buildid: 20170801094618
 0:00.00 LOG: MainThread mozversion INFO platform_version: 56.0a1
 0:00.01 LOG: MainThread INFO Application command: /Users/myk/Projects/gecko/obj-x86_64-apple-darwin15.6.0/dist/Nightly.app/Contents/MacOS/firefox -no-remote -marionette -foreground -profile /var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmp90Ee0y.mozrunner
 0:01.89 LOG: MainThread INFO Profile path is /var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmp90Ee0y.mozrunner
 0:01.89 LOG: MainThread INFO Starting fixture servers
 0:01.98 LOG: MainThread INFO Fixture server listening on http://127.0.0.1:59676/
 0:01.98 LOG: MainThread INFO Fixture server listening on https://127.0.0.1:59677/
 0:02.03 LOG: MainThread INFO e10s is enabled
 0:02.04 LOG: MainThread mozversion INFO application_buildid: 20170801094618
 0:02.04 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:02.04 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
 0:02.04 LOG: MainThread mozversion INFO application_name: Firefox
 0:02.04 LOG: MainThread mozversion INFO application_remotingname: firefox
 0:02.04 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:02.04 LOG: MainThread mozversion INFO application_version: 56.0a1
 0:02.04 LOG: MainThread mozversion INFO platform_buildid: 20170801094618
 0:02.04 LOG: MainThread mozversion INFO platform_version: 56.0a1
 0:02.04 SUITE_START: MainThread 1
 0:02.04 TEST_START: MainThread test_window_minimize.py TestWindowMinimize.test_minimize_stress
13:08.30 TEST_END: MainThread ERROR, expected PASS
Traceback (most recent call last):
  File "/Users/myk/Projects/gecko/testing/marionette/harness/marionette_harness/marionette_test/testcases.py", line 156, in run
    testMethod()
  File "/Users/myk/Projects/gecko/testing/marionette/harness/marionette_harness/tests/unit/test_window_minimize.py", line 36, in test_minimize_stress
    resp = self.marionette.minimize_window()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/marionette.py", line 2056, in minimize_window
    return self._send_message("WebDriver:MinimizeWindow")
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/decorators.py", line 28, in _
    m._handle_socket_failure()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/decorators.py", line 23, in _
    return func(*args, **kwargs)
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/marionette.py", line 731, in _send_message
    msg = self.client.request(name, params)
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/transport.py", line 284, in request
    return self.receive()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/transport.py", line 211, in receive
    raise socket.timeout("Connection timed out after {}s".format(self.socket_timeout))
IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360.0s)
13:08.34 LOG: MainThread INFO Application command: /Users/myk/Projects/gecko/obj-x86_64-apple-darwin15.6.0/dist/Nightly.app/Contents/MacOS/firefox -no-remote -marionette -foreground -profile /var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmpoXj83z.mozrunner
13:10.37 TEST_START: MainThread test_window_minimize.py TestWindowMinimize.test_minimize_twice_restores
26:16.60 TEST_END: MainThread ERROR, expected PASS
Traceback (most recent call last):
  File "/Users/myk/Projects/gecko/testing/marionette/harness/marionette_harness/marionette_test/testcases.py", line 156, in run
    testMethod()
  File "/Users/myk/Projects/gecko/testing/marionette/harness/marionette_harness/tests/unit/test_window_minimize.py", line 25, in test_minimize_twice_restores
    resp = self.marionette.minimize_window()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/marionette.py", line 2056, in minimize_window
    return self._send_message("WebDriver:MinimizeWindow")
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/decorators.py", line 28, in _
    m._handle_socket_failure()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/decorators.py", line 23, in _
    return func(*args, **kwargs)
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/marionette.py", line 731, in _send_message
    msg = self.client.request(name, params)
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/transport.py", line 284, in request
    return self.receive()
  File "/Users/myk/Projects/gecko/testing/marionette/client/marionette_driver/transport.py", line 211, in receive
    raise socket.timeout("Connection timed out after {}s".format(self.socket_timeout))
IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360.0s)
26:16.61 LOG: MainThread INFO Application command: /Users/myk/Projects/gecko/obj-x86_64-apple-darwin15.6.0/dist/Nightly.app/Contents/MacOS/firefox -no-remote -marionette -foreground -profile /var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmpUOmyGZ.mozrunner
26:18.64 LOG: MainThread INFO 
SUMMARY
-------
26:18.64 LOG: MainThread INFO passed: 0
26:18.64 LOG: MainThread INFO failed: 2
26:18.64 LOG: MainThread INFO todo: 0
26:18.64 LOG: MainThread INFO 
FAILED TESTS
-------
26:18.64 LOG: MainThread INFO test_window_minimize.py test_window_minimize.TestWindowMinimize.test_minimize_stress
26:18.64 LOG: MainThread INFO test_window_minimize.py test_window_minimize.TestWindowMinimize.test_minimize_twice_restores
26:18.64 SUITE_END: MainThread 
Summary
=======

Ran 2 tests
Expected results: 0
Unexpected results: 2 (ERROR: 2)

Unexpected Results
==================

ERROR test_window_minimize.py TestWindowMinimize.test_minimize_stress
ERROR test_window_minimize.py TestWindowMinimize.test_minimize_twice_restores
This test is disabled for now. I haven't tested it yet, but I imagine this will be fixed by bug 1373739.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384763
(Reporter)

Updated

a year ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.