Closed Bug 138640 Opened 18 years ago Closed 18 years ago

compress binaries to nearly half size

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 55930

People

(Reporter: brant, Assigned: Matti)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020416
BuildID:    2002041603

The Mozilla binaries could be better compressed.  I compressed the files to
nearly half original size with no known side effects yet.

Reproducible: Always
Steps to Reproduce:
1. Download current mozilla build.
2. View executable sizes.

Actual Results:  Executables are bigger than necessary.

Expected Results:  Compress using UPX or comparable.

The specific command line options I used were:
--best --backup

Version was:
upx 1.20
NRV data compression library 0.82
Copyright (C) 1996-2001 Markus Franz Xaver Johannes Oberhumer
Copyright (C) 1996-2001 Laszlo Molnar
UPX comes with ABSOLUTELY NO WARRANTY; for details type `upx -L'.
This file lists the original and new file sizes and the compression ratios.


*** This bug has been marked as a duplicate of 55930 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.