Change mar generation scripts to exit with an error if xz is not found on the system

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

Attachments

(1 attachment)

Over irc catlee asked for this.
Created attachment 8892630 [details] [diff] [review]
patch
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8892630 - Flags: review?(bhearsum)

Updated

4 months ago
Attachment #8892630 - Flags: review?(bhearsum) → review+

Comment 2

4 months ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/46d7ac61d7cc
Change mar generation scripts to exit with an error if xz is not found on the system. r=bhearsum
Comment on attachment 8892630 [details] [diff] [review]
patch

This is for a build script so this request might not be necessary.

Approval Request Comment
[Feature/Bug causing the regression]: The check for the executable that compresses mar files never existed but now that we changed to using xz it is a good thing to have this check since our build systems are less likely to have xz installed.
[User impact if declined]: None
[Is this code covered by automated tests?]: None
[Has the fix been verified in Nightly?]: Will be used to generate updates today.
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It is for a build script
[String changes made/needed]: None
Attachment #8892630 - Flags: approval-mozilla-beta?
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #3)
> Comment on attachment 8892630 [details] [diff] [review]
> patch
> 
> This is for a build script so this request might not be necessary.
> 
> Approval Request Comment
> [Feature/Bug causing the regression]: The check for the executable that
> compresses mar files never existed but now that we changed to using xz it is
> a good thing to have this check since our build systems are less likely to
> have xz installed.
> [User impact if declined]: None
> [Is this code covered by automated tests?]: None
> [Has the fix been verified in Nightly?]: Will be used to generate updates
> today.
Actually, this hasn't been merged to m-c yet and it will be used to generate updates after it has been merged.

Comment 5

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/46d7ac61d7cc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Do we still need to uplift this for beta 1?
status-firefox56: --- → affected
Flags: needinfo?(robert.strong.bugs)
Not for beta 1. This should land at the same time as the other server side mar generation scripts in Bug 1387241.
Flags: needinfo?(robert.strong.bugs)
Noting this (and the work in bug 1387241) is now waiting to land after we build beta 3. Not for beta 3.
Comment on attachment 8892630 [details] [diff] [review]
patch

Needed for 56 beta 3 to beta 4 watershed/migration to 64-bit.
Attachment #8892630 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Landed on mozilla-beta
https://hg.mozilla.org/releases/mozilla-beta/rev/d95e1a324228b51db76c9e2e545c93abba9bb72a
status-firefox56: affected → fixed
You need to log in before you can comment on or make changes to this bug.