FF hesitates on startup

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: bugzilla, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

1. Launch Firefox
2. Use Options to turn off every possible "check for updates, update search engines, warn me about anything" anything which might cause FF to check for an update, or check for new db entries, or hit any websites or services at all
3. set "delete history and everything else" to clean up your world
4. close FF
5. launch command prompt, type "ipconfig /flushdns"
6. launch FF
7. alt-tab back to command prompt
8. type "ipconfig /displaydns"




Actual results:

Results:

detectportal.firefox.com
----------------------------------------
Record Name . . . . . : detectportal.firefox.com
Record Type . . . . . : 5
Time To Live  . . . . : 3
Data Length . . . . . : 8
Section . . . . . . . : Answer
CNAME Record  . . . . : detectportal.firefox.com.edgesuite.net


Record Name . . . . . : detectportal.firefox.com.edgesuite.net
Record Type . . . . . : 5
Time To Live  . . . . : 3
Data Length . . . . . : 8
Section . . . . . . . : Answer
CNAME Record  . . . . : a1089.d.akamai.net


Record Name . . . . . : a1089.d.akamai.net
Record Type . . . . . : 1
Time To Live  . . . . : 3
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 23.204.103.137


Record Name . . . . . : a1089.d.akamai.net
Record Type . . . . . : 1
Time To Live  . . . . : 3
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 23.204.103.98


a1089.d.akamai.net
----------------------------------------
Record Name . . . . . : a1089.d.akamai.net
Record Type . . . . . : 1
Time To Live  . . . . : 3
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 23.204.103.137


Record Name . . . . . : a1089.d.akamai.net
Record Type . . . . . : 1
Time To Live  . . . . : 3
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 23.204.103.98


Expected results:

Why is FF pinging ANY websites or services?  I have turned off everything I can possibly think of.

I am reporting this because I noticed it while trying to run down a bug where FF hesitates two seconds after being launched, such that attempting to type a URL during that time will stutter/pause/queue keystrokes and later burst them and sometimes lose keystrokes.  I don't know if this is the cause, but it seems to be incorrect behavior at any rate.

I am assuming you are getting my version info along with the bug report. Let me know if you need more data about my config.
Can someone please look at this?
Component: Untriaged → Application Update
Product: Firefox → Toolkit
The address you're seeing get pinged is the captive portal detection service. It contacts that address to see if you're on a network that requires a login or some other action before it will allow connecting to the Internet, so that we can automatically open the required login page.

You can turn that feature off by following the instructions at
https://support.mozilla.org/en-US/questions/1157121#answer-960995

This issue does not involve app update, so I'm moving it back to General and changing the summary to reflect that.
Component: Application Update → General
Product: Toolkit → Firefox
Summary: FF hesitates on startup, checks for updates when I have told it not to → FF hesitates on startup
Below are steps you can take to properly triage bugs like this in the future.

Copy detectportal.firefox.com, open about:config, and paste it into the search field. This returned one pref with the name captivedetect.canonicalURL.

Note: if it returned nothing I would have then searched http://dxr.mozilla.org or http://searchfox.org/ for the value.

I then searched http://dxr.mozilla.org for captivedetect.canonicalURL and the first entry was for a file named browser-captivePortal.js. I clicked the link for this file and looked at the change log. The latest change was bug 1357517 and looking at a few more of the bugs it shows that they are all under Firefox -> General
Perfect. Thank you Robert and Matt.

Comment 5

a year ago
(In reply to bugzilla from comment #0)
> I am reporting this because I noticed it while trying to run down a bug
> where FF hesitates two seconds after being launched, such that attempting to
> type a URL during that time will stutter/pause/queue keystrokes and later
> burst them and sometimes lose keystrokes.

This sounds like a main thread hang/jank. Did it still happen on a clean profile? Do you have any add-ons enabled ?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 6

a year ago
 I think you are right. Removing the ad block extension does seem to  make the  pause/delay go away.  Too bad; it's not like I  I am willing to go without.

Comment 7

a year ago
(In reply to bugzilla from comment #6)
>  I think you are right. Removing the ad block extension does seem to  make
> the  pause/delay go away.  Too bad; it's not like I  I am willing to go
> without.

FWIW, this should be better on newer versions of Firefox and with newer add-ons that are compatible with Firefox 57 (they are marked as such on addons.mozilla.org ). What specific adblocker are you using? For instance, the beta version of uBlock Origin ( https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/?src=ss#beta-channel ) should perform better.
(Reporter)

Comment 8

a year ago
I use AdBlock Plus (currently 2.9.1, the "latest" provided by auto-updating of add-ons). I also have FF on auto-update, so I should be getting the "latest" stable there, also. I rely on FF for work, so I tend to stick with "stable" over "latest".

The core problem for this bug/issue was the unloved "ping", so that is addressed. The separate issue of pause on startup should probably be a new issue if you want to pursue it; otherwise I suggest that somebody go ahead and close this issue.

Comment 9

a year ago
OK, closing as suggested by the reporter in comment #8. ABP is also updating to webextensions, so I expect that will get better once improvements make their way over to stable Firefoxen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.