Increase STALE_CLIENT_REMOTE_AGE from 7 days to 21 days

RESOLVED WONTFIX

Status

()

Firefox
Sync
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: markh, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Once a client is > 7 days old, we hide that client in the UI - you can't send tabs to it, and tabs from that device aren't shown. In bug 1386030 a user considers this "data loss" - they know the device hasn't synced for a week, but also know it has tabs open they care about.

Now that we are able to manually disconnect stale devices, we should consider bumping this limit to (say) 21 days. Given 21 days is the default TTL for client and tab records, we may even be able to remove STALE_CLIENT_REMOTE_AGE entirely.

Ryan/Alex, WDYT?
Flags: needinfo?(rfeeley)
Flags: needinfo?(adavis)
Yes! A week is too short for something like a tablet that you might only get to on a weekend (and not use every weekend).
Flags: needinfo?(rfeeley)
(Reporter)

Updated

a year ago
Duplicate of this bug: 1386030
Agreed.
Flags: needinfo?(adavis)
STALE_CLIENT_REMOTE_AGE helps with duplicates, do we want to remove that? (it could be argued since you can disconnect/hide devices from FxA).
(Reporter)

Comment 5

a year ago
Ed pointed out that I was wrong - we only hide clients after 7 days when there is another identical device name. I suspect that's exactly what happened to the original reporter - he rebuilt his machine and there's a reasonable chance he used the same device and username.

So I think our current behaviour is actually preferred for most users (so they aren't confused about what device they are sending it to) at the cost of doing the wrong thing for a small number of users. So I'm closing this WONTFIX, but Alex or Ryan, please speak up if you think there is something we should change here and I'll reopen it.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Comment 6

a year ago
Wrong, because I were also synced with my wife notebook, and it gone off at the same time.
You need to log in before you can comment on or make changes to this bug.