Closed Bug 1386560 Opened 2 years ago Closed 2 years ago

The Firefox Account header should not be highlighted on search result page.

Categories

(Firefox :: Preferences, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox56 --- verified
firefox57 --- verified

People

(Reporter: evanxd, Assigned: evanxd)

References

Details

(Whiteboard: [photon-preference])

Attachments

(1 file)

The class attribute for the firefoxAccountCategory header is not correct. It supports to be "subcategory" not "searchCategory". It is a typo.
Flags: qe-verify+
The STR:
1. Input the "Account" keyword in search input to search preferences. 

Actual:
The "Firefox Account" on the Firefox Account pane is highlighted.

Expected:
Should not show the "Firefox Account" header since we make the decision in Bug 1382134.
Summary: The class attribute for the firefoxAccountCategory header is not correct → The Firefox Account header should not be highlighted on search result page.
Attachment #8892816 - Flags: review?(jaws)
Hi Jared,

Could you help review the patch?
You could see the STR at Comment 2.

And I think we should uplift this to beta 56.

Thank you.
Status: NEW → ASSIGNED
Whiteboard: [photon-preference][triage] → [photon-preference]
Comment on attachment 8892816 [details]
Bug 1386560 - Fix the typo of firefoxAccountCategory header's class list because all level 1 headers should have the subcategory class.

https://reviewboard.mozilla.org/r/163800/#review170032
Attachment #8892816 - Flags: review?(jaws) → review+
Thank you for reviewing, Jared. Let's land it.
Keywords: checkin-needed
Keywords: checkin-needed
The patch will be landed after the try[1] is good.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9185d302eb4a
Blocks: 1377174
Comment on attachment 8892816 [details]
Bug 1386560 - Fix the typo of firefoxAccountCategory header's class list because all level 1 headers should have the subcategory class.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1365133
[User impact if declined]: The "Firefox Account" header will be shown in search result page if search "Account" but we don't want it happen.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Not yet.
[Needs manual test from QE? If yes, steps to reproduce]: Yes, please refer to https://bugzilla.mozilla.org/show_bug.cgi?id=1386560#c2 to learn the STR.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This is one line xul change, no code change.
[String changes made/needed]: No.
Attachment #8892816 - Flags: approval-mozilla-beta?
The try[1] looks good. Let's land it.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9185d302eb4a
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e65dc2bcc867
Fix the typo of firefoxAccountCategory header's class list because all level 1 headers should have the subcategory class. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e65dc2bcc867
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8892816 [details]
Bug 1386560 - Fix the typo of firefoxAccountCategory header's class list because all level 1 headers should have the subcategory class.

Simple fix, let's bring it to 56 (for beta 1)
Attachment #8892816 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Target Milestone: Firefox 56 → Firefox 57
Build ID; 20170806100257
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Nightly 57.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Build ID: 20170808030909
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Beta 56.0b1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
https://hg.mozilla.org/projects/date/rev/e65dc2bcc867930d4cadea96aa7c2907b5eea163
Bug 1386560 - Fix the typo of firefoxAccountCategory header's class list because all level 1 headers should have the subcategory class. r=jaws
You need to log in before you can comment on or make changes to this bug.